Support » Plugin: Jilt for WooCommerce » WC Deprecated Notice

  • Resolved willgorham

    (@willgorham)


    Hi there,

    Great plugin 🙂 I hope it gets more users because it serves an important e-commerce niche in a really nice way.

    I’m just reporting a deprecated notice:
    “The WC_Order_Item_Meta::__construct function is deprecated since version 3.1. Replace with WC_Order_Item_Product.”

    Called from WC_Jilt_Checkout_Handler::get_product_line_items_for_order() which calls
    SV_WC_Helper::get_order_line_items()

    In my case this notice is coming from the class declared in woocommerce-social-login, but only because it’s declared before the same class contained in Jilt I think.

    Thanks!
    Will

    • This topic was modified 2 years, 3 months ago by willgorham.
Viewing 1 replies (of 1 total)
  • Plugin Contributor Jilt

    (@jilt)

    Hey Will,

    Thanks for the kind words and letting us know about this notice, we’ve fixed it up in our development version and we’ll be pushing out an update soon to resolve it.

    Cheers!
    Max

Viewing 1 replies (of 1 total)
  • The topic ‘WC Deprecated Notice’ is closed to new replies.