WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Warning when adding custom statuses to custom post types

[Resolved] Warning when adding custom statuses to custom post types

  • When I add ‘ef_custom_statuses’ to the ‘supports’ field of my Custom Post Type declaration, I get a warning on the admin page of the CPT:

    Warning: Attempt to assign property of non-object in […]/wp-content/plugins/edit-flow/modules/custom-status/custom-status.php on line 581

    http://wordpress.org/extend/plugins/edit-flow/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Sorry, just spotted this. Do you have any more information on the problem? And are you talking about the function “add_post_type_support” or when you go the “EditFlow”->”Custom Statuses”->”Options” and check the checkbox for that custom post type?

    I’m trying to get Custom Statuses to show up for my CPTs. I had read somewhere that the way to go about that was to add “ef_custom_statuses” to the supports field when declaring a CPT (in functions.php). But when I do that, I get the warning all over the admin panel page for the CPT (to view all posts). It shows up 4 times at the very top, and 6 times under the title of every post. Not sure if I missed a step or something, or maybe this isn’t the way to do it anymore.

    Actually, now that I look at the Edit Flow settings for custom statuses, I see my CPT is checked, but grayed out and it says, “Disabled because add_post_type_support( ‘cpt’, ‘ef_custom_statuses’ ) is included in a loaded file.” below it. So I’m probably not doing it the right way…

    Great plugin overall, just have this one problem.

    Plugin Author Daniel Bachhuber
    Participant

    @danielbachhuber

    I’d recommend removing your code snippet, and instead using the admin interface for activating support based on post type.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Warning when adding custom statuses to custom post types’ is closed to new replies.