WordPress.org

Support

Support » Plugins and Hacks » Warning: call_user_func_array()

Warning: call_user_func_array()

  • I updated the woocommerce plugin from 2.0 to 2.1 and it started showing these warnings:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘wc_setup_product_data’ was given in /home1/harris/public_html/mysite/wp-includes/plugin.php on line 507

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘woocommerce_reset_loop’ was given in /home1/harris/public_html/mysite/wp-includes/plugin.php on line 507

    I have tried searching everywhere on the support page and couldn’t find any solution. Tried to rollback to previous version, didn’t work since the database was already updated.
    Right now my whole plugins page is acting up and not letting me make any changes there.
    The warnings are showing multiple times on both front and backend im guessing.
    I do not have recent backup of my database which i could rollback to get rid of the changes made by 2.1.2 and 2.1.3 versions.
    Is there any solution to this thing out there? any way to rolling back to 2.0.10 version? and rollback the database changes?
    Appreciate a response. Thanks

    https://wordpress.org/plugins/woocommerce/

  • The topic ‘Warning: call_user_func_array()’ is closed to new replies.