WordPress.org

Support

Support » Themes and Templates » [Resolved] W3C HTML5

[Resolved] W3C HTML5

Viewing 6 replies - 1 through 6 (of 6 total)
  • Also the default Twenty Ten theme use html 5 with those attributes, now to make a valid w3c page I need to wait new html 5 specifications ?

    You can still validate against other specification, like “HTML 4.01 Strict” or “XHTML 1.0 Transitional”. You don’t have to validate against HTML 5.

    hello apljdi,
    yes but I need to spend a lot of time to modify themes…

    To validate against HTML 5 you may have to modify themes, but you don’t have to validate against HTML 5. I don’t know what the question is at this point.

    My question is: where I can find a documentation to substitute invalid and deprecated attributes, the online documentation still learn invalid attributes (like microformats wiki).

    At this time I follow your solution, switch html5 templates to xhtml 1.0 transitional…

    http://www.w3.org/TR/html5/

    About 90% of the I just validate and fix, though. I pick up the difference pretty quick that way.

    Thankyou 😉

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] W3C HTML5’ is closed to new replies.