Support » Plugins » W3 Total Cache — Memcache installed, but not detected

  • Hello,

    I run a single server with nginx + php + mysql and am trying to add a smallish memcache cache to the mix.

    As far as I can tell, I have memcache installed, but the W3 Total Cache plugin fails to detect it. I am wondering what steps I can take to troubleshoot this. What is the method used for detection?

    Any initial guidance would be appreciated.


Viewing 1 replies (of 1 total)
  • Meant to say in the above post, this is an Ubuntu server running 10.10. When I run this command:

    php -r 'phpinfo();' | grep 'memcache'

    I get this:

    PHP Warning:  Module 'memcache' already loaded in Unknown on line 0
    memcache support => enabled
    memcache.allow_failover => 1 => 1
    memcache.chunk_size => 32768 => 32768
    memcache.default_port => 11211 => 11211
    memcache.default_timeout_ms => 1000 => 1000
    memcache.hash_function => crc32 => crc32
    memcache.hash_strategy => standard => standard
    memcache.max_failover_attempts => 20 => 20
    Registered save handlers => files user memcache

    And to me, this seems to make me think I have the memcache extension installed. I researched the plugin and its looked for the Memcache class. I’m not sure why I don’t have that class in the mix.

    Again, anyone with any ideas?


Viewing 1 replies (of 1 total)
  • The topic ‘W3 Total Cache — Memcache installed, but not detected’ is closed to new replies.