Support » Fixing WordPress » Visual Editor not working

  • Also html editor will not display what is being typed.

    Reverted to 2010, 2011 and 2012 themes, removed all plugins, checked user “display editor” checkbox, manually uploaded new wordpress files, nothing is working. This is only happening on the http://www.rpk4.com/rant website, all other wordpress sites are working fine.

    htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /rant/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /rant/index.php [L]
    </IfModule>

    # END WordPress

    Maybe something needs to be added?

    Thanks

Viewing 15 replies - 1 through 15 (of 45 total)
  • Moderator t-p

    (@t-p)

    This is only happening on the http://www.rpk4.com/rant website, all other wordpress sites are working fine.

    The one website that has the issue, and all other websites that don’t, do they all have the same plugins and the same theme?

    If not try:
    -deactivating ALL plugins (yes, all) temporarily to see if this resolves the problem. If this works, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can’t get into your admin dashboard, try deactivating via FTP or SFTP or whatever file management application your host provides. If applicible, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old.
    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).
    – To rule out any theme-specific issue, try switching to the unedited default Twenty Twelve theme for a moment using the WP dashboard. If you don’t have access to your admin area, you can switch to the default theme by renaming your current theme’s folder in wp-content/themes and adding “-old” to the end of the folder name using via FTP or SFTP or whatever file management application your host provides.

    All websites are hosted independently, I have 5 other websites that are running wordpress and they are not having this issue. Again, I have:

    1. Reverted to 2010, 2011 and 2012 themes
    2. removed all plugins
    3. checked user “display editor” checkbox
    4. manually uploaded new wordpress files
    5. Reset the cache repeatedly

    The result: visual editor is not working, html sometimes has no display in the text area even though it is caputuring keystrokes from the computer.

    Am wondering if there is a solution in the htaccess file (above).

    http://www.rpk4.com/rant

    Just added

    define(‘SCRIPT_DEBUG’, true);

    to the wp-config file, no change.

    So to review:

    Visual editor does not work. Html editor works, only everything in the editing area is invisible.

    Steps taken (nevermind the simple things like deactivating plugins, display editor check box in user panel, default 2010 theme, etc):

    1. Complete manual upload of fresh wordpress files.
    2. Manually REMOVED all plugins and themes, uploaded new folders with wordpress files
    3. Always, always reset cache and check with Chrome, Firefox and Safari

    Is there something that needs to be changed in the root htaccess file (Above)?

    Thanks

    esmi

    (@esmi)

    Forum Moderator

    Have you tried resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    I have removed the plugin folder and put in the default from a fresh WordPress download, reset the folder, etc.

    Moderator t-p

    (@t-p)

    Manually REMOVED all plugins

    -have you tried resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).

    esmi

    (@esmi)

    Forum Moderator

    Try resetting the plugins folder using Phpmyadmin.

    Please, the issue is so much beyond resetting. I have reset everything. I have restored the site from a backup. And reset again. I believe the problem is in an htaccess file. Any help with that?

    esmi

    (@esmi)

    Forum Moderator

    In some extreme circumstances, resetting the plugins folder via the database is the only solution. If you’re not going to follow up on our suggestions, why bother asking for help?

    Unfortunately I have reset both with phpmyadmin and ftp. I have followed a large number of suggestions before I even posted the issue.

    The host had done some work with the blog portion of the site a few months ago, pre 3.5.1 update, and I am not sure what is supposed to be in the htaccess files. I have read a number of posts about additions into the file but not sure if the fix resolves within there.

    Apologies, but my frustrations are peaking.

    Truly, all help is appreciated.

    esmi

    (@esmi)

    Forum Moderator

    Can you install a fresh copy of WordPress on another server?

    Are you suggesting setting up the blog using the current db backup on another server? I can do that.

    esmi

    (@esmi)

    Forum Moderator

    No – don’t import the current site’s db initially. Just install WP on a new server and see if you have any problems with the editors etc. Then we’ll take it from there.

    I have 5 other seperately hosted sites that have up to date wordpress, none of them are having the same issue

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘Visual Editor not working’ is closed to new replies.