Support » Plugin: Invoice King Pro » View PDF error

  • Resolved lcweb

    (@lcweb)


    Hi,
    I get this error when I click on “View PDF” : FPDF error: Unable to create output file: /usr/share/nginx/prod/wp-content/plugins/invoice-king-pro/themes/default/../../outputs/1221.pdf

    Also “Email PDF” seems not working, I click on it but nothing happens (no messages or other).

    I use WP 3.5.2.

    Thank a lot

    http://wordpress.org/plugins/invoice-king-pro/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Ash Durham

    (@ashdurham)

    Hi Icweb,

    Can you please check that you have made the outputs folder writable on your server? Depending on your server settings, this folder requires to be either 755 or 777 to enable the ability to save the PDF when generated.

    If this has been done and is still erroring, I may need further information on what your trying to generate. If its not the folder permissions its probably data related. ie some characters its not compatible with or the row data has been corrupted.

    Please let me know how you go with the folder permissions and any more information your able to provide would help greatly.

    Thanks

    Ash

    Perfect, now it works (just set permission).

    What about “Email PDF” function? Nothing happens when clicking on button, change only the url to https://www.miodominio.com/wp-admin/edit.php?post_type=invkp_invoices&send=0&send=0

    Do I have to set SMTP server (sendgrid) or other parameters?

    Thank again for your support.

    Plugin Author Ash Durham

    (@ashdurham)

    Hi Icweb,

    Great to hear.

    Regarding the “Email PDF”, the URL is suggesting that the email was unable to send. This link sends the same PDF that you see in “View PDF” to the email address attached to the invoice in question. The field in particular is the email field in the “Client Details” box for the default invoice theme. If you have a theme that has the clients email address on the invoice itself, the system will use that as a backup. The default theme that comes with the plugin doesn’t have this field in its theme and therefore will only use the “Clients Details” field.

    Thanks for your question.

    Great, it works!
    I’ll buy one of your premium themes, maybe that “Clean”, so I’ve not to fill the email address in Client Details box every time.

    Thanks

    Plugin Author Ash Durham

    (@ashdurham)

    Great to hear! 😉

    TIP: Filling out the client details section has its benefits. Not only does it allow you to then save that client in your system for easy generation for next time, clicking the “Insert Details” button will fill all the fields on the invoice that are for the client details for you. You’ll never need to type in the client twice. This also helps if your switching themes that have different client data on them.

    Just a thought 😉

    I’ve been using your plugin for several weeks now and everything was working fine.

    now I’m getting the same error “FPDF error: Unable to create output file: /home3/igitalc9/public_html/arlandsurveyor/wp-content/plugins/invoice-king-pro/includes/../../outputs/377.pdf”

    How do I check the permissions?

    FYI- I just updated to Version 1.1.1 this morning, until I found this post I was thinking the update was the problem.

    OK Just checked -the permissions were 755 I changed to 777 with no luck

    Plugin Author Ash Durham

    (@ashdurham)

    Hi Mike,

    I don’t believe your issue is the same as this one. With the update, I have noticed that it removed all the themes that do not come with the plugin.

    If you have purchased a theme then I would suspect this to be the problem. Can you have a look at this and let me know?

    Thanks

    Ash,

    Thanks for the patience, I’ve been out of pocket.

    You were correct in that the new update deleted my paid theme. I did follow the instructions and re installed the theme. Then, as yoou had indicated might happen, I was asked to up date the theme.

    This is where I am at now:

    After downloading/ installing the new theme, I get a PDF view, but the output is jumbled (words on top of the Logo) and a red box on my WordPress Dashboard asking about the new theme. When I click the link “have you installed the new theme” nothing happens.

    It was two weeks ago, so I’m trying to get up to speed on where I am in exactly in this process, but if my memory serves me correctly, I was thinking the path to the new theme was different than the path indicated by the error.

    Could you clarify, after the update to the plugin, what is the correct path to the theme directory?

    Thanks

    Plugin Author Ash Durham

    (@ashdurham)

    Hi mwfoshee,

    The theme path for the plugin hasn’t changed at all. It should be:

    /wp-content/plugins/invoice-king-pro/themes/your-theme/

    If your receiving the theme upgrade notice then I would suggest the old version is still present in that themes folder. All new themes have a ‘version’ file to determine what version you are running.

    Please make sure that you are running with the latest version of the plugin as well as the latest version of the plugins themes before trying to debug any further issues. The PDF view issue your experiencing could be due to using old versions of files.

    If you are running with the latest versions of everything and still experiencing the PDF view issues then I would recommend reviewing the settings of the plugin and making sure all settings are set, primarily, the column settings. There has been major updates made to the way columns are managed after version 1.1 or the plugin. So far all display issues have been related to this.

    Let me know how you go.

    Thanks

    Finally got it fixed.

    I had to delete all theme and start from scratch.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘View PDF error’ is closed to new replies.