Support » Plugin: Just Custom Fields » Version Php 7

  • Hello, recentlly my server company change the version of php to php 7. The plugin broke, there are some fix to solve this problem?

    Have you in mind fix the plugin to php 7 version?

    Warning: Declaration of Just_Field_SelectMultiple::save($values) should be compatible with Just_Field::save($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/select-multiple.php on line 93

    Warning: Declaration of Just_Field_Checkbox::field($args) should be compatible with Just_Field::field($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/checkbox.php on line 111

    Warning: Declaration of Just_Field_Checkbox::save($values) should be compatible with Just_Field::save($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/checkbox.php on line 111

    Warning: Declaration of Just_Field_Textarea::field($args) should be compatible with Just_Field::field($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/textarea.php on line 128

    Warning: Declaration of Just_Field_Textarea::save($values) should be compatible with Just_Field::save($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/textarea.php on line 128

    Warning: Declaration of Just_Field_DatePicker::field($args) should be compatible with Just_Field::field($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/datepicker/datepicker.php on line 79

    Warning: Declaration of Just_Field_DatePicker::save($values) should be compatible with Just_Field::save($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/datepicker/datepicker.php on line 79

    Warning: Declaration of Just_Field_Upload::field($args) should be compatible with Just_Field::field($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/uploadmedia/uploadmedia.php on line 298

    Warning: Declaration of Just_Field_Upload::save($_values) should be compatible with Just_Field::save($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/uploadmedia/uploadmedia.php on line 298

    Warning: Declaration of Just_Field_FieldsGroup::field($args) should be compatible with Just_Field::field($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/fieldsgroup/fields-group.php on line 178

    Warning: Declaration of Just_Field_FieldsGroup::save($_values) should be compatible with Just_Field::save($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/fieldsgroup/fields-group.php on line 178

    Warning: Declaration of Just_Field_RelatedContent::field($args) should be compatible with Just_Field::field($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/relatedcontent/related-content.php on line 316

    Warning: Declaration of Just_Field_RelatedContent::save($_values) should be compatible with Just_Field::save($args, $instance) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/relatedcontent/related-content.php on line 316

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/just-custom-fields/components/input-text.php:65) in /homepages/31/d439570868/htdocs/cdi-ibense/web/cdi/wp-content/plugins/qtranslate/qtranslate_core.php on line 71

Viewing 1 replies (of 1 total)
  • Plugin Author Alex Prokopenko / JustCoded

    (@aprokopenko)

    Hi,

    Could you please specify what WP version and what JCF version are you using right now?

    Also would be great if you can provide what custom field types you have on your sites (like Select, Input or more complex ones like Upload Media)

    These errors are actually are just Strict warnings and appears depends on PHP configuration. You can turn off strict errors and they will disappear. They do not affect plugin work.

    JCF 3+ should be compatible with PHP 7, however it has a brand new code inside and some field types are deprecated.

Viewing 1 replies (of 1 total)
  • The topic ‘Version Php 7’ is closed to new replies.