Support » Plugin: Contact Form 7 » Version 4.8-dev update

Viewing 6 replies - 1 through 6 (of 6 total)
  • Pulicapus

    (@pulicapus)

    Got it too. After update there are тo longer available jQuery triggers like:

    this.trigger('form-submit-validate', [a, this, options, veto]);

    Hope this a mistake and these triggers will be available on next updates.

    Jos Klever

    (@josklever)

    I looks like a dev version that was published by mistake. I got a notice on multiple sites as well, but when I checked again for updates it was gone again. So you should just stay on the latest version (4.7) or rollback if you already updated. You can do this manually or by using the plugin WP Rollback

    Yep, 4.8-dev was removed again.

    Use Jos’s advice if you updated.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Thomas, thanks for letting us know about this. I myself didn’t see it, but it seems that Contact Form 7 v4.8-dev in the subversion repository was temporarily revealed publicly and many users downloaded it. It was not intended, and I have no idea what caused that.

    The current stable release is Contact Form 7 v4.7. If you have upgraded it to the dev version, please rollback to v4.7.

    Contact Form 7 v4.8 is still in the middle of development. It will be available early next month.

    Tim Derouin

    (@tderouindesign)

    Thanks for the update @takayukister. Had notifications for about 7 sites I manage and was scratching my head!

    KZeni

    (@kzeni)

    Is there any way to make the transition away from on_submit and on_sent_ok more guided & seamless?

    I’d love to see all of the plugins which extend CF7 able to update themselves to use the new methods, and I’d love site admins to see validation warnings regarding their use of on_sent_ok and on_submit before the functionality is removed (and hopefully doesn’t break anything if they’re still left active on forms).

    Also, wish I’d seen this topic before I posted this (though I did provide some additional info & highlighted that people have automatic updates activated & this makes this more serious as many people updated to a version which can break forms): https://wordpress.org/support/topic/cf7-updated-to-4-8-dev-even-though-auto-update-uses-wp-org-current-version/

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Version 4.8-dev update’ is closed to new replies.