Support » Plugin: SSL Insecure Content Fixer » Version 2.2.2 breaks Visual Composer Backend

  • Resolved whaslikeus

    (@whaslikeus)



    Updated to version 2.2.2 and the backend of Visual Composer 5.0.1 no longer works. Frontend is ok. I have to disable SSL Insecure Content Fixer to use VC backend for admin purposes then renable it again. Is there anywhere I can get the old version of SSL Insecure Content Fixer?

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m having the same issue.

    Plugin Author webaware

    (@webaware)

    G’day @whaslikeus @nikmark,

    I’ve done some testing with Visual Composer 5.0.1 and I can’t find any problem. Can you provide some more details please?

    • WordPress version
    • theme and version
    • settings you have for this plugin
    • type of content you are editing when it fails
    • whether you were up-to-date before this new version was released

    Also, is it possible to temporarily switch to a twenty* theme and test?

    If you want to revert to an older version of the plugin, you can get one from this link. Pick a version number link from the section Other Versions.

    https://wordpress.org/plugins/ssl-insecure-content-fixer/developers/

    cheers,
    Ross

    Hi!
    I noticed, after update, when I went to a page in WordPress to edit, and all that came up was a blank white screen. I started deactivating plugins to try and find any conflict, and issue went away when Insecure Content Fixer was disabled. Then I saw @whaslikeus post and saw the issue went away when Visual Composer was disabled. I’m running WordPress 4.7.1 with Flycase theme

    Plugin settings were on Capture (the only setting that works for me) and Standard WordPress function.

    Thanks
    -Mark

    Plugin Author webaware

    (@webaware)

    Thanks. I’m starting to wonder whether it’s a PHP + PCRE (regular expressions) problem. Could you please install this system information plugin so that I can get some more information?

    https://wordpress.org/plugins/wordpress-php-info/

    Once activated, you’ll get a new menu item:

    Tools > WordPress phpinfo()

    From there, please click the button “Email This Information” and send it to:

    support (@) webaware.com.au

    What I’m looking for is the versions of PHP and PCRE running on your website, and any missing extensions that I might be using. The only change I can think of that might be breaking is a new regular expression that uses \K, which was introduced to the PCRE extension in version 7.2, in 2007. I’ve seen a few hosts still running older versions than that.

    cheers,
    Ross

    Plugin Author webaware

    (@webaware)

    Got it, thanks. That rules out \K then.

    Are you able to send me a copy of the theme to test please? Same email address.

    cheers,
    Ross

    Same here, after update all site was broken with a blank page, “Failed to load resurce” i think is a problem with the http/https

    Hi, I started this thread.

    I am running

    WordPress 4.7.1
    theme Bellini Version: 1.38.8

    you can see plugin settings here

    SLL Plugin settings

    Failure occurs on Pages and Products ( i am using WooCommerce)

    My Visual Composer was up to date when I updated.

    It fails in the same way with theme 2017.

    Hope this helps

    Plugin Author webaware

    (@webaware)

    G’day all,

    Well, I can’t exactly replicate what you’re getting.

    I can get a white screen on the front end if I log in to the admin on http (not https), and then try to edit a https page from the front end. That makes sense, because the authentication cookies from logging in on http won’t work on https.

    Otherwise, I can’t get it to break. I can’t even get an error out of it.

    What I can guess is happening is some problem with the AJAX calls. The current version (and previous versions) captured AJAX calls as well as front and back end pages. To test whether this is the problem, I’ve created a revision where Capture doesn’t capture AJAX calls; there’s a new mode Capture All for websites that need that.

    Can you please try this new revision? Let me know whether it works for you, with Capture mode. If it does, can you please also try it with Capture All to see if that breaks it?

    https://www.dropbox.com/s/ctv4uuh56epejfn/ssl-insecure-content-fixer-2.2.3-dev.zip

    If this doesn’t get us anywhere, I’d really appreciate it if one of you can let me look at this problem on a website (preferably a test site) since I just can’t reproduce it locally.

    cheers,
    Ross

    I experienced this same problem. I reverted to 2.2.1 and was fine.

    Plugin Author webaware

    (@webaware)

    G’day all,

    I still can’t replicate the problem, but I have a new hypothesis. Please try this version:

    https://www.dropbox.com/s/mjs1ntsdfrvu1ht/ssl-insecure-content-fixer-2.2.3-dev2.zip

    This version still separates Capture and Capture All, but it also reverts a small change in a regular expression that I suspect could be doing the damage. I’d appreciate it if you could all try this version please.

    @mkassowitz do you have the plugin fixer mode set at Capture?

    cheers,
    Ross

    Tried 2.2.3 and had the same issue. Yes, I am in capture mode with 2.2.1.

    Plugin Author webaware

    (@webaware)

    @mkassowitz did you try the latest one, 2.2.3-dev2, or the earlier one, 2.2.3-dev?

    All: it sounds like I really need one of you to help me out here by making an environment available where I can test this please. I can’t replicate the problem, so I need some help please. I’d prefer a staging site / test environment so that I can play hard, but if that’s not possible, I promise to be very careful if you can only offer a live site.

    cheers,
    Ross

    Same problem here. (WordPress 4.7.1, visual comporser plugin, publisher theme) I have installed ssl-insecure-content-fixer-2.2.3-dev2 and I still have the same problem.

    • This reply was modified 1 year, 9 months ago by  adiestrar.
    Plugin Author webaware

    (@webaware)

    OK, I reckon I have a fix. I’ll release this once I get confirmation from a couple of testers, but in the meantime, here it is pre-release if anyone wants to try it.

    https://www.dropbox.com/s/ugitrqdal9gqy7c/ssl-insecure-content-fixer-2.2.3-dev3.zip

    Many thanks to @jsherk for stepping up and providing an environment where I could test this. It would have taken me a long time to find the problem without that.

    cheers,
    Ross

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Version 2.2.2 breaks Visual Composer Backend’ is closed to new replies.