WordPress.org

Support

Support » Plugins and Hacks » WP Admin No Show » [Resolved] Version 1.4.1 Doesn't Work !

[Resolved] Version 1.4.1 Doesn't Work !

Viewing 14 replies - 1 through 14 (of 14 total)
  • Do you now what version you upgraded from (I assume 1.4.0)? Nothing in the code changed, I just verified that it worked with WP 3.6 and bumped the version number. You might verify the settings on the plugin settings page. Any info you can pass along about your environment (server, wp version, php version), etc. But as I said, no code was changed if you went from 1.4.0 to 1.4.1. I also tested the upgrade scenario on my WP install with no problems.

    Also, did you do an update or delete the old version first? Deleting the plugin will remove the settings from the database. An upgrade will not. The main thing is to check the plugin settings page and see if the blacklist boxes you checked still are and the redirect is set.

    hi, thanks for you support. I just reintall plugin and now everything fine ! Thanks you !

    Awesome, thank you for the update. And thanks for using my plugin!

    I have the same issue after upgrading. I also tried deleting the plugin and re-installing it but that didn’t work too so I restored to the previous version.

    As the current_user_can documentation says:
    Do not pass a role name to current_user_can() …
    I’ve make some changes to the plugin code to use the function described here.

    I have it install with a multisite and buddy press. In the main site works fine, but on the second one users can see the bar and access the admin area. Is this because the plugin does not work in MU?

    Ups! I placed the comment in a resolved issue. Shall I open a new one? Apologies.

    Apparently I missed the comment from @massimopadovan, so I’ll be updating the plugin in the next few days to address that issue.

    @telesemana – I had updated the plugin to deal with multisite a few versions ago. I’m going to make some updates and I’ll see if I can look at that as well.

    Ok, this is what I think I found. When a user signs for MU it gets signed for the root site only, although it can login to other sub sites, those users have no roles unless you take them to the site. Your plugin works if the user has a role in a sub site, but not if it does not. I think they call that state pseudo users. When I gave the user a role on a sub site and its role is blacklisted, then it works. If you can add the pseudo user “role” on the black list, then I guess the problem could be solved. Cheers!

    @telesemana – Awesome, thank you for the detailed info! I’ll be working on the plugin tonight. I’ll probably address current_user_can issue first, and then look into the pseudo user role.

    Excellent, many thanks, keep us posted on your progress, your plugin is very useful, thanks for taking the time to develop it and improve it, and respond so quickly to inquiries 😉

    Happy New Year Doug! Where you able to see at the pseudo user issue for MU? Cheers.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Version 1.4.1 Doesn't Work !’ is closed to new replies.
Skip to toolbar