WordPress.org

Support

Support » Plugins and Hacks » HMS Testimonials » [Resolved] validator error

[Resolved] validator error

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jeff K

    @kreitje

    Can you send me a link to your page so I can take a look?

    On my test site I don’t have that issue.

    Sure… http://www.leitnerconstruction.com

    Thanks for taking a look…

    Sam

    Sorry Jeff, the home page won’t do it (no reviews showing)… go here instead or any internal page: http://www.leitnerconstruction.com/kitchen-remodel/

    Plugin Author Jeff K

    @kreitje

    Ok so here is the issue.

    When using the widget or shortcode it will load an aggregate of all the reviews. So if you are overall 5 out of 5 stars it will show that. If you are 4 out of 5 stars across 20 reviews it will show 4 out of 5.

    Unfortunately there aren’t meta tags I can use (that I know of) to keep this information on the page but not displayed. Therefore I did a div and set the CSS display to none so it doesn’t mess up peoples web page. This is what Google is complaining about.

    I will continue researching the issue to see if I can come up with something.

    Hi Jeff,

    Great progress on this plugin…wondering if you’ve made any headway on the above issue related to aggregate reviews and Google.

    Love to get these ratings appearing in search results.

    Thanks much,

    Sam

    Plugin Author Jeff K

    @kreitje

    Hey Sam,

    After doing some research it does work despite what the validator tool says.

    Screenshot of your Google Results

    Other than that, I can turn it into an option to turn on/off the aggregate review code and actually show the aggregate on the page.

    Hi Jeff, and thanks. I’m not seeing the stars in the search results I pull up, but there they are. Hmmm, so for your idea to turn on/off: what would that look like? For example, I’m using the sidebar widget…would the aggregate display below each review or something?

    Bottom line…if it works, it works. Any idea why I can’t get the same search results?

    Thanks much!

    Sam

    Plugin Author Jeff K

    @kreitje

    The aggregate displays at the top of the first widget or shortcode so it only added 1 time. Right now it is hidden with a style=”display:none;”.

    Instead of a checkbox to turn it on or off, I could make it a dropdown and have these as options: Off, Top of First, Bottom of First, Footer.

    I wish there was a more elegant solution but I haven’t found one yet. I am definitely open to suggestions.

    As for the search results, can you see stars for other websites? Were you logged in or out of google when you do the search?

    Hi Jeff,

    Sorry for the delayed response here…I am seeing the aggregate stars on results from review sites like yelp for instance, but not this site. I’ve tried both logged in and out of google.

    I wish I had a suggestion for you…maybe if there was an option to turn on/off the display:none I might experiment with it, but not critical.

    Thanks,

    Sam

    Plugin Author Jeff K

    @kreitje

    Hey Sam,

    Thanks. I will be working in an option. I don’t have an ETA yet (been really busy) but I will let you know what and when I implement something.

    Plugin Author Jeff K

    @kreitje

    Hey Sam,

    I just pushed an update that added in this option. Let me know if it does or does not work for your needs.

    Jeff

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] validator error’ is closed to new replies.
Skip to toolbar