Support » Fixing WordPress » UTF8 encoding problems

  • Resolved jetsystemservices

    (@jetsystemservices)


    I really do not know if W3 Total Cache is the cause of my problem.
    I already updated to the last version of it.

    My problem started some months ago after a WordPress update but after that the Host did more updates (forced) so I cant go back nor know to which version.

    OK. The problem is that the Pages are being generated with various “?” character in the page but not many and is the only awkward char.

    The page is shown correctly in the Page Editor and I think is being saved correctly in the database. I took the html code from the database and created an html file in notepad and save it in UTF8 encoding and when I open it in the Browser it shows correctly.

    I took the same code and save it in notepad in ANSI encoding, and when opened in the Browser it showed incorrectly exactly the same as shown from the Site Output.

    So is something during the Output process or the Cache process.

    I already tried to disable the Total Cache plugin to test and cleared the Browser cache but still got a bad page. But I do not know if WordPress keeps serving the pages some reminder cache. Chances are the error is not from the plugin.

    This is one of my pages with the problem:
    http://jetsystemservices.com/en/mission/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Rupok

    (@re_enter_rupok)

    Hi there,

    Since W3 Total Cache minify the resources, sometimes it break the scripts. You can try deactivating that particular plugin to make sure it’s causing the issue nor not.

    Cheers!

    Yes. I already tried disabling the W3TC and clearing the Browser cache, but the site keeps rendering with bad chars.

    I would like to add some additional information.

    The bad character is the regular question mark “?” not the question mark inside black diamond. Also is not showing any other bad character.

    I found a thread that relates to the problem:
    https://wordpress.stackexchange.com/questions/194734/blank-spaces-show-as-a-question-mark

    By the way I am not a php programmer, I choose WordPress to make my site because there is little to non programming needed from my part. So please be kind and explain things dummy proof.

    I Delete W3TC plugin from my site but still renders bad chars. So definitely the plugin is not causing the problem.

    So I install it back.

    I also tried to fix by changing the Theme, but it still render the bad chars. So I put back the Theme.

    I found the error.

    It seems that during copy/paste operation I introduced some unprintable chars. This chars during Page creation/edit do not show, but during page rendering show as the “?” char.

    To noticed them I had to opened the file in a HEX editor.

    I had to redo the page to remove the unprintable chars.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘UTF8 encoding problems’ is closed to new replies.