Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support mansurahamed

    (@mansurahamed)

    Hi @royarellano,

    Please go to Ultimate Member->Settings->Page Setup inside your dashboard and see if your user page & other pages are setup correctly. Now go to Pages->Your User Page(Edit) & check if there exist your profile form shortcode. If these settings are fine & still the profile not working go to Settings->Permalinks and update permalink & see if its fixed. If you still have issue let us know which version of UM you are using or have you updated um?

    Thanks.

    Thank you for your response Sir. Per your instructions I verified that the Setup is correct. I then checked each page and they appear to be missing the short code. I’ve reviewed the documentation and cannot seem to find what the appropriate short code must be on each of the pages (User page, Account page, Members page, Register page, Login page, Logout page, Password reset page). And yes, I have the most current version of UM installed (v1.3.88). I even tried reinstalling it and all it did was mess-up a lot of my existing settings.

    Plugin Support mansurahamed

    (@mansurahamed)

    Hi @royarellano,

    Here are the shortcodes

    Account page -> [ultimatemember_account]

    Password Reset Page -> [ultimatemember_password]

    User Page-> Use your profile form shortcode (Please Create one).

    Members -> Use your member directory shortcode from Ultimate Member->Member Directory in dashboard.

    For Login & register page use the default Login & registration form shortcode.

    Logout page doesn’t need any shortcode , just assign the page. Hope this helps.

    Please assign the correct pages in UM settings , You can create forms for your user page and registration page form Ultimate Member->Forms inside the dashboard.

    Thank you.

    Thank you!

    However, this is still unclear. I’m reviewed all of the settings and it isn’t clear to me how to resolve these two items:

    User Page-> Use your profile form shortcode (Please Create one).

    Members -> Use your member directory shortcode from Ultimate Member->Member Directory in dashboard.

    Roy

    Plugin Support mansurahamed

    (@mansurahamed)

    Hi @royarellano,

    Please go to Ultimate Member->Forms inside dashboard , you should see shortcode of your default profile form. Use the shortcode in user page. Then go to Ultimate Member->Member Directory inside dashboard, you should see the shortcode of your default member listing page, use that in members page. This are default settings, in fresh install this settings are set up automatically.

    Thank you.

    Hello @mansurahamed

    I hope this finds you well Sir. Thank you again for your continued support. I was able to correct the some of the issues and I now better understand how the configuration works. Although I must admit it is not so intuitive.

    With regards to the Member Directory, I followed your instructions and I was finally able to get that up and I can see the members accordingly, however when trying to sync the User Roles to the current Users on my WP, the sync feature does not work, so I am left having to manually update each user account individually. This is strange because if you look at the Users the UM field states they are “Members”. And it also would not work using a “Bulk” update. However, once done I was able to see all the members in the directory.

    With regards to the user pages, I followed your instructions accordingly and I am still unable to see the profile. The browser attempts to pull-up the page properly and the permalink is good (https://[domain]/index.php/user/%5Busername%5D/) arrives at a page that states “Nothing Found – Sorry, no posts matched your criteria.”

    Thoughts?

    Thanks again for your time and support.

    v/r,
    Roy

    Plugin Support mansurahamed

    (@mansurahamed)

    Hi @royarellano,

    Please go to Ultimate Member->Settings->Setup inside your dashboard. Then click on reset the section and reassign the pages then save it. Then go to Settings->Permalinks inside the dashboard & update the permalinks. This should solve your issue.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘User Pages Missing’ is closed to new replies.