WordPress.org

Support

Support » Themes and Templates » Urgent help Site stopped working – Array problem

Urgent help Site stopped working – Array problem

  • Dear Friends,

    I am getting the below warning in theme section of WP administration panel. Admin is not showing the theme and unable to open plugin directory.

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/sitename/public_html/wp-includes/theme.php on line 274

    On clicking on error message. the below message apperars

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/sitename/public_html/wp-includes/theme.php on line 274

    Warning: Cannot modify header information – headers already sent by (output started at /home/sitename/public_html/wp-includes/theme.php:274) in /home/sitename/public_html/wp-includes/functions.php on line 1219

    Can Anybody help or this is the error due to webspace in tmp folder.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You might check your permissions on the wp-content, wp-content/themes and wp-content/plugins folder. If necessary make them 777.

    See:
    Changing File Permissions

    I just developed the same problem, not sure what I did but was following some tutorial about changing permission to allow write access to the WP Content folder. I went back and checked and the write permission will not stick. I can’t upload a file from within the Adm Panel so I was trying to troubleshoot. Now I can’t even view my blog on the web any further.

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /nfsn/content/gazetotheright/public/wordpress/wp-includes/theme.php on line 298

    Actually, when checking via my FTP program, trying to access WP_Content, it says no such file or directoy when I try to double click on it to open.
    Very odd indeed.
    Tim

    I can access the directory and all folder now, all files appear to be the exact same size as the ones I’ve back up in the content theme directory, but have major problems somewhere. I’ll be up all night watching for a reply.
    Many thanks in advance
    Tim

    sounds to me like your ftp software and website are out of sync

    Well, I guess some of the experts around here get a kick out of watching us panic, then figure it out while waiting on an answer 😉
    I finally just tried changing all the file permissions to allow on all three levels, which surely can’t be a good idea, but it worked… what a relief.
    Tim

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Urgent help Site stopped working – Array problem’ is closed to new replies.
Skip to toolbar