Support » Plugin: MapSVG Lite » Uploaded SVG not appearing

  • Resolved Jay Collier

    (@jcollier)


    After uploading an SVG, I opened the map dashboard and received this error:

    MapSVG needs width/height or viewBox parameter to be present in SVG file.

    What do I add to the file so it will be acceptable to MapSVG?

Viewing 5 replies - 1 through 5 (of 5 total)
  • BTW, the files *does* have a viewbox parameter.

    <svg version=”1.2″ baseProfile=”tiny” id=”ME” xmlns=”http://www.w3.org/2000/svg&#8221; xmlns:xlink=”http://www.w3.org/1999/xlink&#8221; x=”0px” y=”0px” viewBox=”60 27 720 540″ xml:space=”preserve”>

    Plugin Author RomanCode

    (@oyatek)

    Hi,

    Usually that means your server doesn’t know what is a SVG format and it gives SVG files without proper mime-type headers. The proper mime-type header for SVG files is “image/svg+xml”. When server doesn’t know what is SVG it servers SVG files as “plain/text”.

    Please Google “how to add svg mime type for server [Apache / ngnix / IIS]. (choose your server).

    • This reply was modified 1 year, 1 month ago by RomanCode.
    • This reply was modified 1 year, 1 month ago by RomanCode.
    Plugin Author RomanCode

    (@oyatek)

    [solved]

    Not solved. The hosting administrator, SiteGround, confirmed that the server is configured to support image/svg+xml mime types. In addition, as I mentioned earlier, the file has a viewbox parameter. Perhaps something else is happening.

    • This reply was modified 1 year, 1 month ago by Jay Collier.

    Now solved. I installed the SafeSVG plugin and Map SVG Lite recognized it. All set!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Uploaded SVG not appearing’ is closed to new replies.