Support » Everything else WordPress » Upload image error, maybe cgi/php problem.

  • The error:
    Uploaded file couldn’t be moved to /var/www/localhost/htdocs/wordpress/wp-content/uploads/2007/06.
    Warning: Cannot modify header information – headers already sent by (output started at /var/www/localhost/htdocs/wordpress/wp-admin/admin-functions.php:1965) in /var/www/localhost/htdocs/wordpress/wp-includes/functions.php on line 1348

    My directories permissions are OK:
    wp-content # ls -l
    total 16
    -rw-r–r– 1 root root 32 May 17 02:50 index.php
    drwxr-xr-x 3 root root 4096 May 17 02:50 plugins
    drwxr-xr-x 7 root root 4096 Jun 6 15:21 themes
    drwxr-xr-x 4 root root 4096 May 17 02:50 uploads

    uploads # ls -l
    total 8
    drwxr-xr-x 3 root root 4096 May 17 02:50 2006
    drwxr-xr-x 5 root root 4096 Jun 11 14:26 2007

    2007 # ls -l
    total 12
    drwxr-xr-x 2 root root 4096 May 17 02:50 02
    drwxr-xr-x 2 root root 4096 May 17 02:50 03
    drwxr-xr-x 2 root root 4096 May 18 14:47 05

    My webserver software is Cherokee-0.5.6, and this error have appeared when I upgraded wordpress from 2.1 to 2.2

Viewing 4 replies - 1 through 4 (of 4 total)
  • I had the same thing happen to me!!!

    I can’t seem to fix it though…

    I posted about it here: http://wordpress.org/support/topic/122922#post-578015

    ¬°¬°Solved!!

    I do not have the same problem before updating to wordpress-2.2.1, and now I know what was the problem.

    The dirs in wordpress/wp-content/uploads has to be owned by cherokee in my case.

    Change to wordpress/wp-content/uploads directory and do:

    # chown -R cherokee:cherokee *

    Hi Juan,

    I encounter the same problem you described.
    You’re the lucky one because you solved it.
    I still have it. I try to change the owner of the dir, not by # chwon, but via a GUI, but the result is the same. Cherokee, is that your Webserver?

    Regards,

    Rob

    Yes, Cherokee is the webserver.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Upload image error, maybe cgi/php problem.’ is closed to new replies.