Support » Installing WordPress » Upload error

  • Hi ,
    I have installed the wordPress 2.5 on subfolder in my site ( http://www.*****.com/wordpress

    The word press is runing fine but i can not UPLOAD any image , I get the error message : HTTP error.

    I tried to set the uploads folder that located in wp-content folder to the permission 777 & 755 and the same error message continues ..

    I contacted my host and the told me that phpsuexec is runing on our server and better to ask the WORDpress support about the right permission for phpsuexec server

    Thanks alot

Viewing 15 replies - 1 through 15 (of 66 total)
  • Moderator kmessinger

    (@kmessinger)

    word press is runing fine

    So you can post, etc. correct?
    What is your URL?

    You get this message: HTML error when uploading an image from the wp-admin/write screen?

    my URL is
    http://www.dollarat.com/press

    From admin panel I go to WRITE tap in order to start new post , then i click on Upload image ICON next to the word ( Add Media ) , and then i started uploading with no success

    Moderator kmessinger

    (@kmessinger)

    So you are browsing to a file, giving it a title and uploading it?

    Can you see your WP files on the server? You should have, under wp-content a uploads folder and under that an 03 folder.

    Sorry, and what kind of HTML error?

    I can not give the file a title since its not uploaded .

    I borwes my computer to upload a file ( image ) and i get the error when it tries to upload the files .

    The error is : HTTP error

    Moderator kmessinger

    (@kmessinger)

    The uploads folder should be 755. The 08 folder should be 755. The month (03) folder should be 777. AFAIK.

    Phpsuexec has caused problems in the past for some but I know nothing about it.

    Also Mod_Security on the server has caused problems with images.

    I would first guess server problem.

    I had the exact same problem and solved it. I didn’t have a .htaccess file in my wordpress folder, which seemed to be the problem.

    I wasn’t sure how to make one, but remembered WordPress gives you an example when you try to change the permalink structure. So I copied the example (admin panel:settings/permalinks page) made a textfile called .htaccess and uploaded it to the main wordpress folder.

    Problem fixed. Uploads working again. Hope this works for you too.

    It seems many guys have this problem..one is me.. hope it will be resolved in WP 2.5

    Just found this thread while searching for a solution of exactly the same problem.
    For me it was a permission problem but I think that “HTTP error.” is definitely the wrong description of it!

    Also, after uploading the image (when you can enter the title and so on), there is another error:
    Warning: realpath(): Unable to access /var/www/****/httpdocs/wp-admin/wp-content/uploads in /var/www/****/httpdocs/wp-includes/functions.php on line 1056

    The media directory is set to “wp-content/uploads” which works fine except for this error! Seems that it tries to do realpath() with the wrong base directory (the wp-admin dir, not the real base path)…

    Didn’t search for this last error but I hope it will be noticed by someone before the final 2.5 release! (BTW it’s 2.5 RC2 running here 😉 )

    Running 2.5 as of todays release (3/29). mod_security is on and the image uploader is not working for me.

    Image upload box opens fine. Clicking browse opens my PCs dialogue box to choose an image. When uploading the image (..”crunching”..) I get a pop up error box that says:

    Error #2044: Unhandled IOErrorEvent:. text=Error #2038: File I/O Error.

    Then WP gives me the message “An error occurred in the upload. Please try again later”.

    From the server error log I see this:

    ==cb6c7746==============================
    Request: XXX.com 11.222.33.444 – – [29/Mar/2008:13:08:34 -0500] “POST /wp-admin/async-upload.php HTTP/1.1” 406 363 “-” “Shockwave Flash” – “-“
    Handler: application/x-httpd-php
    —————————————-
    POST /wp-admin/async-upload.php HTTP/1.1
    Accept: text/*
    Cache-Control: no-cache
    Connection: Keep-Alive
    Content-Length: 29393
    Content-Type: multipart/form-data; boundary=———-GI3Ef1ei4KM7ae0Ef1gL6Ij5ei4gL6
    Host: xxx.com
    User-Agent: Shockwave Flash
    mod_security-message: Access denied with code 406. Error processing request body: Multipart: final boundary missing [severity “EMERGENCY”]
    mod_security-action: 406

    (domain name and IP edited out)

    Running on a nix system; apache 1.x, php 4.x

    mod_security is the culprit.

    Changing the .htaccess to turn off mod_security yielded no success either. Hosts that run mod_security will have no gallery love?

    bug?

    After a bit of troubleshooting, adding this to the .htaccess file in my WP root worked:


    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Turns mod_sec off on the async-upload.php file.

    Bless you LSRN94, after two hours of searching that one did the trick. Thanks

    I’m getting the http error as well, but am not sure what content to include in my .htaccess file. I checked the permalinks page for the example elfebel mentioned but can’t find it – if anyone could post the full code that should be in the .htaccess file I’d greatly appreciate it.

    I also contacted my server and they said that these two errors show up repeatedly in the php server log for my site:

    [29-Mar-2008 15:46:03] PHP Fatal error: Call to undefined function image_downsize() in /home/.sites/111/site30/web/blog/wp-includes/post.php on line 2326

    [29-Mar-2008 16:13:03] PHP Fatal error: Call to undefined function wp_constrain_dimensions() in /home/.sites/111/site30/web/blog/wp-admin/includes/image.php on line 173

    help anyone??

    I had the same problem. Only by changing the permissions on the wp-content directory itself was I able to get around it.

    It appears that WordPress 2.5 stores uploaded files directly in the wp-content directory, NOT in the uploads subdirectory. So changing permissions on the uploads subdirectory (which I had tried first) did nothing.

    If WP is storing uploads in the wp-content directory, that would be really stupid.

Viewing 15 replies - 1 through 15 (of 66 total)
  • The topic ‘Upload error’ is closed to new replies.