Support » Plugin: UpdraftPlus WordPress Backup Plugin » Updraftplus backups to Google not completing

  • Resolved ckyoga

    (@ckyoga)


    I am trying to setup Updraftplus to backup to my Google Drive. I have plenty of space but the uploads zip file is quite large. It never finishes which, in turn, means the file never makes it to the google drive. Please help! We are on the free version right now but I want to recommend the premium to my client if I can get it working.

    We have the latest plugin version: 1.16.17
    WordPress 5.2.4 running twentyfifteen theme.
    I set the PHP Max_execution_time in php.in from 60 to 90

    Error message from log:
    0199.178 (0) Google Drive: quota usage: used=507.1 MB, total=15360 MB, available=14852.9 MB
    0199.180 (0) Google Drive: backup_2019-10-25-0131_Community_Farm_Kitchen_0717a0ab4aa3-uploads.zip: Attempting to upload to Google Drive (into folder id: 1L050erc8uoX-BqeiBqDyWqKlkD1SM_Od)
    0199.617 (0) Googledrive chunked upload: 0.6 % uploaded (1048576)
    0199.785 (0) Googledrive chunked upload: 1.1 % uploaded (2097152)
    01

    0263.867 (0) Google Drive: Upload error: Operation timed out after 60000 milliseconds with 0 bytes received (line: 117, file: /wp-content/plugins/updraftplus/includes/Google/IO/Curl.php)
    0263.935 (0) An error condition has occurred for the first time during this job
    0264.105 (0) Google Drive: quota usage: used=510.6 MB, total=15360 MB, available=14849.4 MB

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support bornforphp

    (@bornforphp)

    @ckyoga Could you try to reduce the backup archive split size. This will split the backup into smaller, more manageable files.

    To do this, open the ‘expert settings’ section of the UpdraftPlus Settings tab, and find the ‘split backups every’ option. Set this to 25Mb save your settings and run a new process.

    If the issue persists, please ask your hosts/server admin to investigate their PHP error logs. These logs should contain more information on the exact issue that is causing the backup process to halt.

    Kind Regards,
    Harshad

    Thank you! Is the split feature free or premium?

    My host company already told me they will not alter their settings or investigate further but the split would work. If the backup is over 105M it fails to send.

    best,
    Caroline

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi,

    The split archive feature is available for free version.

    Regards,
    Bryle

    Thank you for your help so far.

    I am still running into a problem. I have been trying to set the split archive value and it is still giving me an error. I have tried 100M, 75M and 50M on the split archive value. Any ideas? I may need to look elsewhere for a backup solution.

    Here is a snippet from the error log:
    0237.637 (0) Googledrive chunked upload: 97.6 % uploaded (49283072)
    0237.815 (0) Googledrive chunked upload: 99.6 % uploaded (50331648)
    0297.820 (0) Google Drive: Upload error: Operation timed out after 60000 milliseconds with 0 bytes received (line: 117, file: /public_html/wp-content/plugins/updraftplus/includes/Google/IO/Curl.php)
    0297.822 (0) An error condition has occurred for the first time during this job
    0298.041 (0) Google Drive: quota usage: used=3169.2 MB, total=15360 MB, available=12190.8 MB
    0298.043 (0) Google Drive: backup_2019-10-30-0523_Community_Farm_Kitchen_757799315c8e-uploads4.zip: Attempting to upload to Google Drive (into folder id: 1L050erc8uoX-BqeiBqDyWqKlkD1SM_Od)

    best,
    Caroline

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi Caroline,

    Please can you send us full copy of the backup log?
    This can be found in the UpdraftPlus Existing Backups tab.
    Please use an online service such as Dropbox or Pastebin, and post the link here.

    Regards,
    Bryle

    I figured out a way to get the backups to run. The split function was always failing. If I just reduced the backup size of the uploads directory and excluded some files that are large and will not change the backup runs.

    However, I am having an issue. Right now we are using the Free version. When I do a remote backup to google drive the files go across correctly and the older backups are removed. But, for every backup kept on google drive Updraftplus retains the local copy. Our hosting company limits us on size and I do not want the local copy retained after the remote backup to google drive successfully completes. Is there a way to get it to remove the local copy once the remote copy is complete?

    Ultimately I want to use the premium version to retain a combination of monthly, weekly and daily backups over on Google Drive. With this setup the hosting environment will not be able to handle local copies of the site that many times.

    best,
    Caroline

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi Caroline,

    Apologies for the late reply.

    If you want to keep a copy of the backups on your remote storage only, you need to enable “Delete local backup”. Delete local backups” option can be enabled in UpdraftPlus > Settings tab > Show Expert Settings.

    For you to be able to do more sophisticated backup retention rule, you will need UpdraftPlus Premium. Please see FAQ: https://updraftplus.com/more-sophisticated-backup-retention/

    Regards,
    Bryle

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.