It looks like not all WordPress core files were installed correctly during the update. I’d recommend performing a manual update to fix this. See: https://wordpress.org/documentation/article/updating-wordpress/#manual-update
exactly what @threadi wrote👍🏻
Thread Starter
henlon
(@henlon)
Now I made the manual update but at the instruction to delete the .maintenance file I can’t find that file.
I get the same error message when I try to login at the admin site.
If the .maintenance file isn’t there, it’s no big deal. Its presence would indicate that an update is still in progress.
Did you really re-upload all the files in /wp-includes/? That’s where the file that’s apparently missing is located.
On the other hand, I took a closer look at the error message. It’s caused by the AcyMailing plugin, which attempts to integrate styling using WordPress core functions. Try deactivating this plugin by simply renaming it in the /wp-content/plugins/acymailing/ directory. After that, the website should be working again.
Afterward, I’d recommend reinstalling the plugin. You may have had a version that isn’t compatible with WordPress 7.0.2. If the reinstallation also results in this error, please contact AcyMailing support for clarification: https://wordpress.org/support/plugin/acymailing/
Thread Starter
henlon
(@henlon)
Thanks for your help.
No I have reinstalled the /wp-includes/ library and renamed the acymailing directory.
The same error remains
The error message has already changed, but it still indicates that the core files are not properly installed.
I see the following options for you:
- Try deactivating all plugins by renaming their directory to
/wp-content/plugins/. This will rule them out as the cause.
- Check whether the file
/wp-includes/view-transitions.php exists. That file contains the missing function. If it’s not there, upload it again (possibly along with the entire directory).
- Also check the PHP files in the main directory of your WordPress installation. Did you update those as well? The
view-transitions.php file is included via wp-settings.php. If that hasn’t been updated, make sure to do so.
Thread Starter
henlon
(@henlon)
Fantastic
The problem seems to be that wp-settings.php was not copied.
I had to delete the original file and then copy the new one.
After that I could enter the page again. I activated the plugins and they seems to work.
Thank you for all your help.