Support » Theme: Astra » Uncaught TypeError

  • Resolved zenjukai

    (@ecoist)


    Hey folks,

    I have the latest of Astra and Astra Pro plugin … and I am getting this error when looking at the console. Any thoughts?

    Uncaught TypeError: Cannot read property 'querySelector' of null
        at n (frontend.min.js?ver=3.0.2:1)
        at frontend.min.js?ver=3.0.2:1
    n @ frontend.min.js?ver=3.0.2:1
    (anonymous) @ frontend.min.js?ver=3.0.2:1
    load (async)
    (anonymous) @ frontend.min.js?ver=3.0.2:1
    (anonymous) @ frontend.min.js?ver=3.0.2:1

    Cheers

Viewing 15 replies - 1 through 15 (of 25 total)
  • Hello @ecoist

    Sorry for any inconvenience.

    We have found the cause and were able to reproduce this issue, and we will be fixing the same in the upcoming update releasing soon by next week.

    I hope that helps. 🙂 Looking forward to getting this resolved.

    Regards,
    Suman 🙂

    Thread Starter zenjukai

    (@ecoist)

    Perfect, thank you Suman for the quick reply and solution. =)

    Cheers

    Hey Team Brainstorm,

    just in case my problem is a different one, I get a similar error.

    Uncaught TypeError: can't access property "querySelector", i is null.

    I can provide you further details if needed.

    I’m some sort of able to reproduce the problem. My problem is bound the Astra Theme and Elementor Pro. To be more specific, this problem “always” occur when I implement the global header template from Elementor Pro.

    I tested all Plugins one by one and so it always comes to Elementor Pro and Astra. Not the Astra Pro Addon.

    I tested multiple versions of the Elementor and Elementor Pro Plugin and it didn’t help. What helped was to install an older version of Astra. When I installed the Astra theme version 2.6.2, there is no problem at all.

    But there is one thing I don’t understand. I think it’s kinda dependent on how I installed my plugins. Unfortunately I can’t remember anymore what I did a few weeks ago, but installing a complete new WordPress website and installing my Plugins from the WordPress Backend (instead of FTP) I could somehow bypass this problem. So I can’t explain why some of my websites get this error and others not.

    All I can tell, it started with the 3.0 update. Normally I copy all my plugins via FTP or the C-Panel of my hosting provider into my website and start buildung from there on.

    After building the client website for about 30 hours I haven’t the time anymore for a new/clean/fresh website and I don’t want to modify any files which will be potentially updated by you.

    Edit:
    https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1

    That’s the file which catches the error.

    The full error log by FireFox:

    Uncaught TypeError: can't access property "querySelector", i is null
        n https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1
        <anonymous> https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1
        EventListener.handleEvent* https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1
        <anonymous> https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1
    frontend.min.js:1:2751
        n https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1
        <anonym> https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1
        (Async: EventListener.handleEvent)
        <anonym> https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1
        <anonym> https://my-example-domain.com/wp-content/themes/astra/assets/js/minified/frontend.min.js?ver=3.0.2:1

    Regards,
    Max

    Hi @justmeandmyself,

    It seems that it’s the same issue. Please just let us know if you still get the same error after you update to the upcoming update.

    Kind regards,
    Herman 🙂

    Hey thanks for the reply, sounds good.

    I will give an update on this issue when I finish my project and do my updates before launch 🙂

    Hey,

    just a quick question.
    Shouldn’t the next/upcomming update with the hotfix released this (today is the 02/12/21) week?

    Best regards
    Max

    Hello @justmeandmyself

    Sorry for the delay. We had some things to be added, our expected update with the fix will be released early next week. 🙂

    We appreciate your patience and understanding.

    any news on this? Im getting the same error on 3.0.2

    Anna

    (@annatje84)

    Hello,

    I think I have the same error. I can’t apply the header to the entire website. I have Astra theme and Elementor Pro.
    I get 405 error and this in my log:
    Uncaught TypeError: Cannot read property ‘querySelector’ of null
    at n (frontend.min.js?ver=3.0.2:1)
    at frontend.min.js?ver=3.0.2:1

    and:

    /wp-json/elementor/v1/site-editor/templates-conditions/119669:1 Failed to load resource: the server responded with a status of 405 ()

    How to fix this?

    Hey guys,

    as far I can tell the hotfix still wasn’t released so I also get the same error as you. The patch should have been released early this week as you can read in the official post of Brainstorm above, but it wasn’t, so I guess they having some difficulties.

    I forgot to add some details on my last post. The error exist now for some time and the last time I mentioned the error (02/12/21) I had the following version details:

    Astra Version: 3.0.2
    Elementor Version: 3.1.1
    Elementor Pro: Version 3.0.10

    Thread Starter zenjukai

    (@ecoist)

    Hey folks,

    Still getting the exact same errors as I did when I first posted this issue.

    I know they are on top of it, but it does seem like they are having some issue with it.

    Hopefully they can get it resolved soon.

    Cheers

    • This reply was modified 1 year, 5 months ago by zenjukai.

    Hello guys,

    Sorry for the delay!

    The release is lined up and should be released this week very soon.

    We appreciate your patience and understanding!

    Same here, when using Elementor Pro with WooCommerce Product Related widget: Product Related title, price and rating not showing.

    Astra Version: 3.0.2
    Elementor Version: 3.1.1
    Elementor Pro Version: 3.0.10
    WordPress Version: 5.6.2

    • This reply was modified 1 year, 5 months ago by lapser.
    • This reply was modified 1 year, 5 months ago by lapser.

    The issue is severe with Elementor Pro. And only happens to Astra theme. Elementor builder keeps freezing because of this error. Please fix this fast. Our production pages are having trouble.

    Astra’s one of the main strength is Elementor as Astra as a theme is very lightweight. Please solve this ASAP.

    Thanks in advance.

    Hello @raihandanordic / @ecoist and others,

    We have released an update v3.0.3 for this fix, please update and let us know if that helps. 🙂

    Looking forward to hearing from you.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Uncaught TypeError’ is closed to new replies.