WordPress.org

Support

Support » Plugins and Hacks » [Resolved] UMapper 1.3.71 Javascript error

[Resolved] UMapper 1.3.71 Javascript error

  • After automatically upgrading a couple of times to the lastest release of the UMapper plugin (1.3.71), I’m unable to use the plugin by clicking on the U icon in my post entry. The URL for the U icon is this javascript:// and after I click it I get an error message in the status bar of Internet Explorer that reports that on line 312 window.tinyMCE.activeEditor is null or not an object. I’ve tested this in both IE 6 and 7 with the same results. I haven’t tested it yet in Mozilla Firefox 3.0.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Actually, I haven’t tested it to work in IE (admin side of application – on client side plug-in should work w/o problems), if you were able to use plugin previously, then you need to make hard refresh (Ctrl + F5), to purge your cache – once cleaned, plugin js should start functioning as expected.

    Please, let me know if that cures the problem.

    Thanks,
    Victor

    I’m afraid that doing a hard refresh both within the Dashboard view and within the post editing window itself does not cure this problem. The client side works fine in IE 6 & 7, but I’m unable to call up the plugin by clicking on the U icon. The plugin had worked for editing, with a minor bug that you fixed, in WordPress 2.6 up until at least version 1.1.8.

    Thanks for letting me know – I will be working on fix right now, would notify you once I have sth to show.

    Victor.

    Thanks Victor. I can now confirm that this problem also exists with plugin version 1.3.71 in Mozilla Firefox 3.0.

    Victor, I saw that you’d uploaded a new version (1.3.75) today, so I installed that and got the same error in both IE 7 and Firefox 3.0. A hard refresh of the browser has no effect, there’s simply a blank URL/URL showing in the status bar that’s referencing a script. I also downloaded and installed the latest version of Safari (3.1.2) for Windows Vista. The plugin does not work with it either. I do not use any kind of caching with my WordPress site. I noticed that you claim that IE 7 does not play well with WordPress. I have not found this to be true at all, at least on the admin and plugin side, and in fact the only plugin that I’m continuing to have problems with is UMapper. Maybe it’s something to do with the Zend framework and the unclosed PHP tags. I’ll look forward to any kind of resolution you can offer.

    DigitalArchivist, do you use the visual or html editor?

    I have a similar problem as you using the html editor. In the visual editor it works fine, but if I’m using the html editor I get no error message, just nothing happens. But, if I switch to the visual editor, and then back to the html editor, then it works again.

    Conf:
    WP 2.6, Umapper 1.3.6, Firefox 3.0, Windows XP.

    Thanks very much for that tip. I use the html editor and have consistently. I noticed the Visual/HTML tabs had disappeared from the post window area, but only after reenabling the visual editor while I was using Safari. The disappearance probably happened between an upgrade from WP 2.5.x to 2.6. I just never noticed. The plugin works again in IE 7 and Safari.

    Hello, guys!
    I would try to make sure that UMapper is supported in IE in the next major version. Please allow me couple of days, and then you’d be able to use UMapper w/o problems in IE, and probably (if I have enough time) in Safari.

    Thanks,
    Victor

    Hello guys,

    I am running into the same problems with the following details:
    WP 2.6, Umapper 1.3.95, Firefox 2.0, Windows XP.

    The suggested solutions won’t work either…

    I cannot use UMapper as described above – UMapper WP Plugin 1.40 | WP 2.6 using the code editor | FF 3.0 | the link for the icon in the media manager is javascript:// and nothing happens when it the icon is clicked.

    Just tried it with Google Chrome and same results

    Frustrating and annoying as the examples and look very nice as well as appearing to be a technology with lots of potential.

    thx

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] UMapper 1.3.71 Javascript error’ is closed to new replies.
Skip to toolbar