Support » Fixing WordPress » Trouble with YouTube embedding

  • Hey guys!
    I’m pretty noob with WordPress and I’m having trouble with my first upload. I didn’t find a topic with the same issue.
    I’m trying to embed YouTube-vide but in preview it displays only part of it.
    Is this how it should be?
    Sami

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steve Stern

    (@sterndata)

    How are you trying to embed the video? The easiest way is to paste the URL for the viewing page on a line by itself.

    Please provide a link to a page on your site where we can see this. Thanks.

    Unfortunately I can’t provide link to preview. I should not publish the article before it works.
    I have tried to:
    – Paste the embed code in the text editor. In this case I can’t see anything. The code just disappears.
    – Paste the basic url to visual editor (In this case https://www.youtube.com/watch?v=JvcCFeI61zA&t=4s). In this method it provides results as in attached picture.
    – Tried to create new media and paste the URL code there. Same results.

    Moderator Steve Stern

    (@sterndata)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    sko93,

    Have you check the CSS for the embedded YT iframe/area? Maybe the height is not set correctly. You can use Chrome Developer Tools [F12 to open it] to look into the settings by select the element [click on the left icon, cursor with the box]

    If it in fact the CSS property is wrong, then you can correct it yourself. If theme allow custom CSS, you can set the height property to auto.

    If theme does not allow custom css, you need to create a file and link to to your theme.

    Of course, you can wait for the theme developer to correct it or use a different theme.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.