Support » Themes and Templates » Trouble with submit buttons

  • Resolved Uh Oh Spaghetti Os

    (@uh-oh-spaghetti-os)


    Hi all,

    I’m using SendPress in conjunction with WooCommerce (not sure if this is related, but its how I found the issue)

    Both of these implement buttons, both of which use the following code:

    #container input[type="submit"] {
    	background: none repeat scroll 0 0 #9A150B;
    	border: 0 none;
    	color: #FFFFFF;
    	font-size: 14px;
    	letter-spacing: 1px;
    	float: right;
    	margin-top: 5px;
    	padding: 5px;
    	width: 70px;
    	font-family: 'Rockwell';
    	cursor: pointer;
    	position: relative;
    	left: -8px;
    	bottom: 55px;
    }

    Now, the problem I’m having is that since these buttons are on difference pages, the styling has to be different

    I guess what I need to do is change it so that one page uses:

    #primary input[type="submit"] {
        background: none repeat scroll 0 0 #9A150B;
        border: 0 none;
        color: #FFFFFF;
        font-size: 14px;
        letter-spacing: 1px;
        float: right;
        margin-top: 5px;
        padding: 5px;
        width: 70px;
    	font-family:'Rockwell';
    	cursor:pointer;
    	position:relative;
    	left: 5px;
    	bottom: 45px;
    }

    Could anyone point me in the right direction to find out how to do this?

    Thanks

    [Note: Provide a link to the issue if you want someone to help]
    [General CSS issues can be discussed in general CSS forums]

Viewing 1 replies (of 1 total)
  • Double post

    If anyone stumbles upon this and is looking for a solution, I basically went into the template file that was creating the button, and changed its class to something else, then set formatting rules for that in the CSS

Viewing 1 replies (of 1 total)
  • The topic ‘Trouble with submit buttons’ is closed to new replies.