Support » Themes and Templates » Trouble with drop down menu

  • Hey Guys,

    I’ve got an install of WP 3.5 and a custom theme installed on my site.

    I’ve got 2 menus at the top near the header…

    Check Site

    One works perfectly showing the correct drop down etc, the other doesnt.

    I’ve got the menus configured properly in the admin area, and checking my code shows this:

    'theme_menu_depth' => 0,
    'theme_menu_source' => 'Pages',

    in the defaults code.

    then the code on the header.php

    This one doesnt work

    <nav class="art-nav-top clearfix">
        <?php
    	echo theme_get_menu(array(
    			'source' => theme_get_option('theme_menu_source'),
    			'depth' => 0,
    			'menu' => 'top-menu',
    			'class' => 'art-hmenu'
    		)
    	);
    ?>
        </nav>

    This one works

    <nav class="art-nav clearfix">
        <?php
    	echo theme_get_menu(array(
    			'source' => theme_get_option('theme_menu_source'),
    			'depth' => 0,
    			'menu' => 'primary-menu',
    			'class' => 'art-hmenu'
    		)
    	);
    ?>
        </nav>

    It shows everything except the second level…. Any ideas what I’ve done wrong?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    There’s nothing wrong here. Why would you expect the far-top menu to work, to drop down?

    WPyogi

    (@wpyogi)

    Forum Moderator

    Have you asked on the Artisteer site?

    Hey,

    Yeah the support section has sub pages, should show 3 or 4 pages in a drop down, like the web services section.

    I’ve not spoken to artisteer yet but I did post around 3 or 4 days ago on the artisteer forum and had no reply 🙁

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    If you don’t apply CSS or JavaScript to the menu, then it won’t work.

    Artiseer themes aren’t supported here, so you should continue your posts on their forums.

    Hey,

    Ok, thanks anyway, thought I’d ask here but it is covered by CSS,

    the <nav class="art-nav-top clearfix"> and <nav class="art-nav clearfix"> covers the code and the adds ul il etc elsewhere in the code.

    If you look in the source code you will see the code for the drop down is shown, but for some reason it wont show – I didnt know if there was an obvious setting that I’d missed.

    esmi

    (@esmi)

    Forum Moderator

    We do not support Artisteer themes here – only those themes downloaded from wordpress.org.

    Oh ok, never mind, I thought this would be the better place to ask about it, I’ll keep looking. Thanks anyway

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Trouble with drop down menu’ is closed to new replies.