WordPress.org

Support

Support » Plugins and Hacks » WP-Piwik » [Resolved] Tracking doesn't work

[Resolved] Tracking doesn't work

  • Both on my piwik installation (I maintain two sites) and at the local Piwik data within WP there is no data recorded for my WP site after upgrading to WP 3.8, while the JetPack shows at least more visitors, I will try to manually appending the javascript instead of using WP-Piwik.

    http://wordpress.org/plugins/wp-piwik/

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author braekling

    @braekling

    Can you give a more detailed description? The WP-Piwik settings are still fine? The tracking code is added to WordPress as expected?

    I have reinstalled the plugin yesterday, I used the same sited and Api key as is stated on my main piwik install for my wordpress site. Did that yesterday and this morning the counter was still stuck at 0…

    I take it the tracking code is not added to WP.

    Plugin Author braekling

    @braekling

    Adding the tracking code is enabled? And is the tracking code fetched as expected?

    Maybe you are using this “audio bar” plugin?
    http://wordpress.org/support/topic/wp-piwik-in-conflict-with-audiobar-plugin?replies=2

    I have the same problem. Using WP 3.8

    When I add the API key and click save, I get the message:
    An error occured: Please check URL and auth token. You need at least view access to one site.

    Now I’m pretty sure my url and api key are correct. I enabled auto-config and I see there are two blogs (I only have one) with the exact same name in my Piwik dashboard, but both show 0 traffic.

    I see the following error message when I run system check:

    Error:
    Try #1: LOAD DATA INFILE : SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user ‘piwik’@’localhost’ (using password: YES)[28000],
    Try #2: LOAD DATA LOCAL INFILE : SQLSTATE[42000]: Syntax error or access violation: 1148 The used command is not allowed with this MySQL version[42000]

    I’m using MySQL version 5.5.33 and PHP 5.5.7 on Debian Wheezy. Pretty sure the password is OK but I will recheck

    Plugin Author braekling

    @braekling

    WP-Piwik does not access your Piwik database. So the SQL errors should be caused by Piwik itself.

    Did you try to disable WP-Piwik’s caching as mentioned in different support threads? (Settings -> Tracking)

    Hi,

    Disabling caching indeed fixed the wp error message on the plugin.

    Now I still have the remaining problem that piwik appears to not work for me at all. I think it’s a compatibility issue between my (super) recent version of MySQL and what piwik expects.

    Plugin Author braekling

    @braekling

    Sorry, but I can’t help you with Piwik issues. Have a look at the Piwik community instead: http://piwik.org

    Yeah, I know. Separate things.

    Thanks for your help with the plugin.

    Cheers

    Hello,

    I am also seeing the same problem on three of my blogs, and nothing I tried so far seems to have helped:

    1. Updated Piwik — it’s now on 2.0.2
    2. Updated WP — 3.8
    3. Updated WP-Piwik — 0.9.9.7
    4. Configuration — reset, no difference
    5. Auth token — reset password, copied new token, no difference

    I also unticked “Enable cache” under WP-Piwik -> Piwik Settings — no difference.

    I get two different errors:
    – under “Home”:
    An error occured: Piwik did not answer. Please check your entered Piwik URL.
    – under “Piwik Settings”:
    An error occured: Please check URL and auth token. You need at least view access to one site.

    Of course, both the URL and auth token are correct (please note, this happens on three different blogs).

    Piwik itself works perfectly fine, which is evident when I add the tracking code manually; however WP-Piwik itself does not add any code.

    Running the tests under “Support” however gives correct results:
    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    HTTP/1.1 200 OK, expected XML
    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    HTTP/1.1 200 OK, expected XML

    Maybe a useful hint is that the “Get site configuration details” link does not seem to get the right Piwik ID for the site, even though it does get the title and URL.

    If I can venture a guess, are we facing a problem parsing the XML maybe?

    Thanks for any help and please let me know if I can provide more information.

    Regards,
    Mihnea

    I have exactly the same problem like Mihnea described above on my blog.
    best regards
    Chris

    Yep, here the same problem 🙁

    The tracking link seems to be added ok though, so this must be a Piwik problem, not a WP-Piwik problem.

    Hm but before the wp-piwik update, piwik works fine …

    Dit anyone contact Piwik already? The’ve made the upgrade, WP-Piwik did as did WordPress. Three points of possible failure.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] Tracking doesn't work’ is closed to new replies.
Skip to toolbar