Support » Plugin: Forums - wpForo » Topic Add Error

  • Resolved Vinsanity

    (@vinsanity)


    Installation succesfully done, but when I try to crate a topic with my superadmin profile (no one is already registered) the sentence in object “Topic Add Error” pops on right top corner and nothing happens.

    How can I solve it?

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Contributor gVectors Team

    (@gvectors-team)

    Hi Vinsanity,
    it seems you you have a JS error on your website. This error affects wpForo JS functions. Please leave some URL to allow us debug it.

    hello and thanks for your quick response!
    here my website: http://vikingsfc.altervista.org/community/

    Plugin Contributor gVectors Team

    (@gvectors-team)

    I can’t debug it, the registration is disabled.

    sorry, you’re right!!
    Now should be active!

    Let me know if you need an admin login to trace the problem 🙂

    Plugin Contributor gVectors Team

    (@gvectors-team)

    Please send some user login details to support[at]gvectors.com email address. I can’t complete my registration.

    just sent 🙂 ty!

    @gvectors-team let me know if you have received the email and if you need any kind of further action from my side 🙂

    Plugin Contributor gVectors Team

    (@gvectors-team)

    Thank you Vinsanity,
    we found the problem. This depends on MySQL version of your hosting service. Topic and Post wpForo tables have not been created on plugin activation. We’re fixing this right now.

    sounds great! thank you!!!

    Plugin Contributor gVectors Team

    (@gvectors-team)

    ok, problem is solved. your hosting service mysql database doesn’t support innoDB database engine and some tables have not been created. I fixed this issue, it should works fine.

    you’re just amazing! thanks a lot!!!!

    i’ve the same problem how can I fix it?
    my blog is hosted on altervista.org service.

    Plugin Contributor gVectors Team

    (@gvectors-team)

    There are a very few hosting services which doesn’t support InnoDB storage engine. You should open hosting > cPanel > phpMyAdmin database manager, navigate to SQL tab and execute this SQL code to create all necessary tables. Please replace all wp_ prefixes in this code to your database table prefixes, if they are wp_ just use it as is:

    CREATE TABLE IF NOT EXISTS wp_wpforo_accesses (
      accessid int(10) unsigned NOT NULL AUTO_INCREMENT,
      access varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      title varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      cans longtext COLLATE utf8mb4_unicode_ci NOT NULL COMMENT 'forum permissions',
      PRIMARY KEY (accessid),
      UNIQUE KEY access (access(191))
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_forums (
      forumid int(10) unsigned NOT NULL AUTO_INCREMENT,
      title varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      slug varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      description longtext COLLATE utf8mb4_unicode_ci,
      parentid int(10) unsigned NOT NULL DEFAULT '0',
      icon varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      last_topicid int(10) unsigned NOT NULL DEFAULT '0',
      last_postid int(10) unsigned NOT NULL DEFAULT '0',
      last_userid int(10) unsigned NOT NULL DEFAULT '0',
      last_post_date datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
      topics int(11) NOT NULL DEFAULT '0',
      posts int(11) NOT NULL DEFAULT '0',
      permissions text COLLATE utf8mb4_unicode_ci,
      meta_key text COLLATE utf8mb4_unicode_ci,
      meta_desc text COLLATE utf8mb4_unicode_ci,
      status tinyint(1) unsigned NOT NULL DEFAULT '0',
      is_cat tinyint(1) unsigned NOT NULL DEFAULT '0',
      cat_layout tinyint(1) unsigned NOT NULL DEFAULT '0',
      order int(10) unsigned NOT NULL DEFAULT '0',
      PRIMARY KEY (forumid),
      UNIQUE KEY UNIQUE SLUG (slug(191))
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_languages (
      langid int(10) unsigned NOT NULL AUTO_INCREMENT,
      name varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      PRIMARY KEY (langid),
      UNIQUE KEY UNIQUE language name (name(191))
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_likes (
      likeid int(10) unsigned NOT NULL AUTO_INCREMENT,
      userid int(10) unsigned NOT NULL,
      postid int(10) unsigned NOT NULL,
      post_userid int(10) unsigned NOT NULL,
      PRIMARY KEY (likeid),
      UNIQUE KEY userid (userid,postid)
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_phrases (
      phraseid int(10) unsigned NOT NULL AUTO_INCREMENT,
      langid int(10) unsigned NOT NULL,
      phrase_key varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      phrase_value text COLLATE utf8mb4_unicode_ci NOT NULL,
      PRIMARY KEY (phraseid),
      UNIQUE KEY lng_and_key_uniq (langid,phrase_key(191)),
      KEY langid (langid),
      KEY phrase_key (phrase_key(191))
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_posts (
      postid bigint(20) unsigned NOT NULL AUTO_INCREMENT,
      parentid bigint(20) unsigned NOT NULL DEFAULT '0',
      forumid int(10) unsigned NOT NULL,
      topicid bigint(20) unsigned NOT NULL,
      userid int(10) unsigned NOT NULL,
      title varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      body longtext COLLATE utf8mb4_unicode_ci,
      created datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
      modified datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
      likes int(10) unsigned NOT NULL DEFAULT '0',
      votes int(11) NOT NULL DEFAULT '0',
      is_answer tinyint(1) unsigned NOT NULL DEFAULT '0',
      is_first_post tinyint(1) unsigned NOT NULL DEFAULT '0',
      PRIMARY KEY (postid),
      FULLTEXT KEY title (title),
      FULLTEXT KEY body (body),
      FULLTEXT KEY title_plus_body (title,body)
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_profiles (
      userid int(10) unsigned NOT NULL,
      title varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL DEFAULT 'member',
      username varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      groupid int(10) unsigned NOT NULL,
      posts int(11) NOT NULL DEFAULT '0',
      questions int(11) NOT NULL DEFAULT '0',
      answers int(11) NOT NULL DEFAULT '0',
      comments int(11) NOT NULL DEFAULT '0',
      site varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      icq varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      aim varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      yahoo varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      msn varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      facebook varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      twitter varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      gtalk varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      skype varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      avatar varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      signature text COLLATE utf8mb4_unicode_ci,
      about text COLLATE utf8mb4_unicode_ci,
      occupation varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      location varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      last_login datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
      rank int(10) unsigned NOT NULL DEFAULT '0',
      like int(10) unsigned NOT NULL DEFAULT '0',
      status varchar(8) COLLATE utf8mb4_unicode_ci DEFAULT 'active' COMMENT 'active, blocked, trashed, spamer',
      timezone varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL,
      PRIMARY KEY (userid),
      UNIQUE KEY UNIQUE ID (userid),
      UNIQUE KEY UNIQUE USERNAME (username(191))
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_subscribes (
      subid bigint(20) unsigned NOT NULL AUTO_INCREMENT,
      itemid bigint(20) unsigned NOT NULL,
      type varchar(5) COLLATE utf8mb4_unicode_ci NOT NULL,
      confirmkey varchar(32) COLLATE utf8mb4_unicode_ci NOT NULL,
      userid bigint(20) unsigned NOT NULL,
      active tinyint(1) unsigned NOT NULL DEFAULT '0',
      PRIMARY KEY (subid),
      UNIQUE KEY itemid (itemid,type,userid),
      UNIQUE KEY confirmkey (confirmkey),
      KEY itemid_2 (itemid),
      KEY userid (userid)
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_topics (
      topicid bigint(20) unsigned NOT NULL AUTO_INCREMENT,
      forumid int(10) unsigned NOT NULL,
      first_postid bigint(20) unsigned NOT NULL DEFAULT '0',
      userid int(10) unsigned NOT NULL,
      title varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      slug varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      created datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
      modified datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
      last_post bigint(20) unsigned NOT NULL DEFAULT '0',
      posts int(11) NOT NULL DEFAULT '0',
      votes int(11) NOT NULL DEFAULT '0',
      answers int(11) NOT NULL DEFAULT '0',
      views int(10) unsigned NOT NULL DEFAULT '0',
      meta_key text COLLATE utf8mb4_unicode_ci,
      meta_desc text COLLATE utf8mb4_unicode_ci,
      type tinyint(4) NOT NULL DEFAULT '0',
      closed tinyint(1) unsigned NOT NULL DEFAULT '0',
      has_attach tinyint(1) unsigned NOT NULL DEFAULT '0',
      PRIMARY KEY (topicid),
      UNIQUE KEY UNIQUE SLUG (slug(191)),
      FULLTEXT KEY title (title)
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_usergroups (
      groupid int(10) unsigned NOT NULL AUTO_INCREMENT,
      name varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL,
      cans longtext COLLATE utf8mb4_unicode_ci NOT NULL COMMENT 'board permissions',
      description text COLLATE utf8mb4_unicode_ci,
      PRIMARY KEY (groupid),
      UNIQUE KEY UNIQUE GROUP NAME (name(191))
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_views (
      vid int(10) unsigned NOT NULL AUTO_INCREMENT,
      userid int(10) unsigned NOT NULL,
      topicid int(10) unsigned NOT NULL,
      created timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP,
      PRIMARY KEY (vid)
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    
    CREATE TABLE IF NOT EXISTS wp_wpforo_votes (
      voteid int(10) unsigned NOT NULL AUTO_INCREMENT,
      userid int(10) unsigned NOT NULL,
      postid int(10) unsigned NOT NULL,
      reaction tinyint(4) NOT NULL DEFAULT '1',
      post_userid int(10) unsigned NOT NULL,
      PRIMARY KEY (voteid),
      UNIQUE KEY userid (userid,postid)
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci; 
    • This reply was modified 9 months, 1 week ago by  gVectors Team.

    Hi,
    I am facing the same issue. I have checked MySQL version is 5.6.34 that I am now using. I tried pasting the code into my phpAdmin but it vomited syntax errors at line 20.

    *I have replaced all of the prefix to wpwq_ that is being used in my db.

    Here is the error message :
    Error
    SQL query:

    CREATE TABLE IF NOT EXISTS wpwq_wpforo_forums ( forumid int(10) unsigned NOT NULL AUTO_INCREMENT, title varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL, slug varchar(255) COLLATE utf8mb4_unicode_ci NOT NULL, description longtext COLLATE utf8mb4_unicode_ci, parentid int(10) unsigned NOT NULL DEFAULT ‘0’, icon varchar(255) COLLATE utf8mb4_unicode_ci DEFAULT NULL, last_topicid int(10) unsigned NOT NULL DEFAULT ‘0’, last_postid int(10) unsigned NOT NULL DEFAULT ‘0’, last_userid int(10) unsigned NOT NULL DEFAULT ‘0’, last_post_date datetime NOT NULL DEFAULT ‘0000-00-00 00:00:00’, topics int(11) NOT NULL DEFAULT ‘0’, posts int(11) NOT NULL DEFAULT ‘0’, permissions text COLLATE utf8mb4_unicode_ci, meta_key text COLLATE utf8mb4_unicode_ci, meta_desc text COLLATE utf8mb4_unicode_ci, status tinyint(1) unsigned NOT NULL DEFAULT ‘0’, is_cat tinyint(1) unsigned NOT NULL DEFAULT ‘0’, cat_layout tinyint(1) […]

    MySQL said: Documentation

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘order by int(10) unsigned NOT NULL DEFAULT ‘0’,
    PRIMARY KEY (forumid),
    ‘ at line 20

    Thank you.

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.