WordPress.org

Support

TinyMCE Issue

  • acheashadow
    Member

    @acheashadow

    Hi Guys,

    A few weeks ago my write post/page went funny in IE7 and I thought that maybe it was a bug, then it failed in FF3.. Basically in IE7 if I create a post it says

    “Your attempt to edit this post: “post name” has failed.

    Please try again.

    But it places the post into the drafts.

    This has now started happening in FF3 aswell and on closer inspection on IE7 I see an error.. heres the error:

    Line: 4
    Char: 1
    Error: Syntax error
    Code: 0
    URL: http://www.xboxer360.com/wp-admin/post-new.php

    Upon further inspection within that php file I see nothing wrong with this code:

    $parent_file = 'post-new.php';

    Now something tells me this is a TinyMCE issue as none of my buttons on the wysiwyg are the style they were before and the HTML / VISUAL have ceased to work. I need a fix for this and I really don’t know where to start!

    Many thanks in advance!

Viewing 9 replies - 1 through 9 (of 9 total)
  • acheashadow
    Member

    @acheashadow

    heres another error I get:

    Line: 85
    Char: 9
    Error: ‘tinyMCE’ is undefined
    Code: 0
    URL: http://www.xboxer360.com/wp-admin/post-new.php

    acheashadow
    Member

    @acheashadow

    Ive installed tinyMCE and ive deleted all my temp net files and history in IE7 and still no joy?

    acheashadow
    Member

    @acheashadow

    Surely someone must know whats wrong?

    It sounds like an incomplete or mixed installation. I would recommend you delete everything except your themes, plugins, htaccess, and similar, and completely re-upload your wordpress isntallation.

    (oh, take a backup copy of your files first, just in case, okay?)

    acheashadow
    Member

    @acheashadow

    Ive tried that to no avail! anyone?

    acheashadow
    Member

    @acheashadow

    Ive fixed it by following these guidelines:

    For others coming across the same error with version 2.51,

    Edit the following file: yoursite/wp-includes/js/tinymce/tiny_mce_config.php

    First, comment out (by instering // before the code) while ( @ob_end_clean() ); at around line 13. It is immediately preceded by // Discard any buffers

    Then, search for “compress” until you find ‘compress’ => true and change the “true” to “false.

    If you have the same problem with version 2.5, you only need to worry about the compression setting.

    Prasad Thombre
    Member

    @prasadthombre

    Wow Gr8 hack…. I was facing this problem since last week, now This solves my problem with wordpress 2.6.2 also.

    Thanks
    myloverswish.com

    xs650head
    Member

    @xs650head

    G’day, is there any way that I can resolve this problem from my PC at home? or do I need my web hosting company to do it for me.
    As you can probably already guess I have no clue as to what you guys are talking about but I do know this – I no longer can edit my web page and the ‘visual editor’ has gone, I get the ‘tinymce error. I posted before and managed to find a workaround but it no longer seems to work. I have tried ff and 1e7 but both give the same result.
    xs650head@hotmail.com
    support@perthprinterrepair.com.au

    cheers
    keith

    robbyslaughter
    Member

    @robbyslaughter

    acheashadow’s trick also worked for me on WordPress 2.6.5.

    I should note that this problem appears to be caused by a combination of issues in the TinyMCE code AND the behavior of modern browsers, so if you come across this page, keep that in mind as you are troubleshooting!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘TinyMCE Issue’ is closed to new replies.