Support » Plugins and Hacks » Yet Another Related Posts Plugin (YARPP) » Thumbnails Options Using Wrong Thumbnails

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’ve spent over an hour reading faqs, reading this forum, and tinkering with the settings.

    The problems seems to be that YARPP is simply not accessing my thumbnails. My theme has thumbnails enabled, and they work well in my archives. I use “Site Layout Customizer” to generate a front page, and it accesses my thumbnails fine.

    Somehow, though, YARPP isn’t able to access my thumbnails, and so is just putting a shrunken version of the entire featured image in its place. This is slowing down my site quite a bit, since my site has a lot of art on it, and those files are huge.

    If i put the yarpp-template-thumbnail.php display option up, I don’t get thumbnails at all. I simply get full-sized pictures! It should be accessing my thumbnails, and has “the_post_thumbnail();” written right into the code, but it is accessing the whole image instead.

    Would you please explain how I can get YARPP to access my thumbnails? I don’t want to have to generate an entirely new set of thumbnails, just have it access the ones I already have. I’m going to have to turn off the thumbnails if this can’t be fixed.

    Thank you again for the plugin. I wouldn’t be raising this if I didn’t want to use it.

    I’ve solved it. I’ve also found an elegant solution to the problem from this thread:

    http://wordpress.org/support/topic/yarpp-not-using-the-square-thumbnails?replies=15

    I went the opposite to the approach of generating thumbnails for YARPP, and instead made YARPP fit the thumbnails I already had.

    I went and rewrote one line of code in template-thumbnails.php:

    $post_thumbnail_html = get_the_post_thumbnail( null, $dimensions['size'] );

    and had instead:

    $post_thumbnail_html = get_the_post_thumbnail( null, 'thumbnail' );

    This solve the problem perfectly. Instead of trying to find or generate thumbnails that matched my YARPP settings, I had YARPP get the thumbnails that were already there. It simply grabbed my 150×150 thumbnail, shrunk it to 120×120 and tada!

    Please let me know if you have any questions. I think this would be an elegant solution to the thumbnail issues in future versions.

    ^^ I was looking for this solution forever! Thank you!!

    After switching the code my website loads a lot faster now!

    Thanks dude!

    Would it be safe to remove this lines also? (from template-thumbnails.php)

    $this->diagnostic_generate_thumbnails() )
        $this->ensure_resized_post_thumbnail( get_the_ID(), $dimensions );

    Thanks for this – I tried the solution above and it also works for me.

    My theme seems to have generated 120×120 and 150×150 thumbnails – yet YARPP still used a distorted resized version.

    Apart from this issue – have been happy with YARPP so far.

    Thanks once more.

    Frank

    Please read the info in the YARPP readme’s FAQ section about setting the yarpp thumbanail size.

    You don’t want to modify the files in YARPP itself, as they will be overwritten when you upgrade YARPP.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Thumbnails Options Using Wrong Thumbnails’ is closed to new replies.