Support » Plugin: RSS Image Feed » Throwing errors

  • Resolved AndalusianWorld

    (@andalusianworld)


    logs error:
    24-Feb-2014 20:54:30] PHP Warning: get_headers() [function.get-headers]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /blog/wp-content/plugins/rss-image-feed/class-lib/A5_ImageClass.php on line 271
    [24-Feb-2014 20:54:30] PHP Warning: get_headers() [function.get-headers]: This function may only be used against URLs in /blog/wp-content/plugins/rss-image-feed/class-lib/A5_ImageClass.php on line 271
    [24-Feb-2014 20:54:30] PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /blog/wp-content/plugins/rss-image-feed/class-lib/A5_ImageClass.php on line 106
    [24-Feb-2014 20:54:30] PHP Warning: get_headers() [function.get-headers]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /blog/wp-content/plugins/rss-image-feed/class-lib/A5_ImageClass.php on line 271
    [24-Feb-2014 20:54:30] PHP Warning: get_headers() [function.get-headers]: This function may only be used against URLs in /blog/wp-content/plugins/rss-image-feed/class-lib/A5_ImageClass.php on line 271

    https://wordpress.org/plugins/rss-image-feed/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author tepelstreel

    (@tepelstreel)

    Find line 113 – 115 in the file A5_ImageClass.php and eliminate

    $is_image = self::check_url($thumb);
    
    if ($is_image === false) return false;

    There are some problems that the check_url should solve. Obviously, it causes problems itself every now and then.

    That should help at first.

    Thank you,
    Will give it a shot

    Will this be fixed in a future update? I keep going back to an old version because of the errors.

    Plugin Author tepelstreel

    (@tepelstreel)

    At one point, it will be fixed. First, there are other projects on my list. Did you try the above mentioned fix?

    It worked for the latest 2 blogposts. The rest didn’t get an image in the feed. Reverted back to 2.2. Will wait for a new version as the old one works great for me :).

    Plugin Author tepelstreel

    (@tepelstreel)

    Thanks for mentioning that. I never could reproduce the errors. So, I really need feedback. At least I have a point from where I can start now. 🙂

    Cheers

    No problem. Extra info: I have the lastest WP install, I always have images in my post and a featured image.

    Plugin Author tepelstreel

    (@tepelstreel)

    Now, the problem should be fixed. Also missing image didn’t ever occure in my testing environments.

    Best

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Throwing errors’ is closed to new replies.