Support » Fixing WordPress » Theme wont load

  • Just got into wordpress and i cant seem to figure out why my theme wont load when i try to view the address from a different computer? The computer it is hosting from loads the page just fine through localhost and also the IP address. Any suggestions?

Viewing 15 replies - 1 through 15 (of 17 total)
  • ?

    esmi

    (@esmi)


    Forum Moderator


    Have you tried the using the default theme and seeing if you get the same problem? It might help to determine whether this is a theme issue or something else.

    no but i will try it now, thanks for the idea

    Nope still loads messed up, its just a white page with the text from the site but all to the left

    I think i might have found the problem but i dont know how to fix it. It looks like its only loading fully from localhost, but if i go to a different computer and use the ip it only loads text, if i try to add a comment it automatically changes the address from http://x.x.x.x/blogname/ to http://localhost/blogname/ and fails to connect?

    esmi

    (@esmi)


    Forum Moderator


    That sounds more like a server/network problem to me.

    @esmi, any suggestions?

    ?

    esmi

    (@esmi)


    Forum Moderator


    Out of my area of expertise, I’m afraid, I know just enough about network configuration to be dangerous. However, I’ve added a couple of tags to the topic in the hopes attracting the attention of one of the network gurus.

    Visit Settings -> General and change the URL values from localhost to a real address or resolvable name.

    Every computer in the world thinks that it is named localhost…

    ok i found where that is and changed it, and after i saved the settings now i get a page not found

    well somehow when i changed the localhost to the ip it changed the name it was looking for now it is saved and keeps looping to login or page not found because its redirecting to a name that doesnt exist?

    Does anyone know the file that is configured when you are logged into you admin account and you change settings?

    That would be your mysql database.

    So out of curiosity, what did you specify for the URL values at Settings -> general?

    If it needs to be corrected, have a look at Changing_The_Site_URL for some options.

    well i went to change the localhost url to the ip of my computer, but when i did it i made it x.x.x.x/spydan instead of x.x.x.x/spydaink so its looking for spydan everytime i try to login

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Theme wont load’ is closed to new replies.