Support » Plugin: Easy Theme and Plugin Upgrades » The plugin isn't working anymore.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Chris Jean

    (@chrisjean)

    The new 2.0.0 version no longer modifies the installer page. It now automatically handles identifying if the plugin or theme needs to be upgraded.

    Please try upgrading a plugin or theme to confirm that things are working properly. You should see messages indicating that a backup was created and that the plugin/theme was upgraded successfully.

    Could be more helpful, if a message was displayed that it now handles everything automatically since first thing people think is that hey, I can’t see this option, must be broken. 🙂

    I agree. I thought the plugin was broken. If is going to auto detect then you should let users who are use to the old way know about it.

    Plugin Author Chris Jean

    (@chrisjean)

    I’m sorry for the confusion. The primary reason for the big change was that for many users, the plugin simply did not work. After working with some of the users, I found that the plugin had to alter many of the ways it worked in order to allow for these users to be able to use the plugin.

    I found a couple of sites where the compatibility issue was triggered by modifying the pages where the theme or plugin file is selected (the pages that originally had details about upgrading and selecting “Yes” from the drop down). Since WordPress doesn’t have any hooks that specifically allow modification of the content on that page, my way of doing so was basically a hack that worked for most people. However, I confirmed from those users’ sites that it creates problems for others.

    So, the only way to allow more people to successfully use the plugin was to make drastic changes to how the plugin functioned, including the removal of any modification to the pages used to select the theme or plugin to upload. I could have added a message and then removed it at a later date, but that would mean that those users would have to wait until that later date before they could use the plugin.

    I wish that there was a way to fix the old problems without creating confusion, but in this case, that simply wasn’t possible.

    Plugin Author Chris Jean

    (@chrisjean)

    In order to better help confused users find details about the change (it was previously only in the changelog and support requests such as this one), I added details to the plugin’s description and FAQ pages.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘The plugin isn't working anymore.’ is closed to new replies.