Support » Themes and Templates » Template Problems in IE

  • JSDavis82

    (@jsdavis82)


    could someone please take a look at my site [http://jeffrey-davis.net/blog] and see if you can figure out what’s making my template shift to the right and outside the wrapper in IE?

    thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Chris_K

    (@handysolo)

    I’d start by going after some of the validation issues.

    JSDavis82

    (@jsdavis82)

    yikes, well that was pretty messy, but it now passes xhtml 1.0 validation, yet the aforementioned IE error is still occurring, can you provide any further assistance? thanks.

    JSDavis82

    (@jsdavis82)

    still need help here, if someone would be so kind as to take a look. thanks

    Chris_K

    (@handysolo)

    Look at #holder and that margin-left: 30;

    I’m not positive, but I’d try removing that and see what happens with IE and FF.

    JSDavis82

    (@jsdavis82)

    hmm, i tried removing it and it looked <i>almost</i> perfect in IE, but FF pulled the left margin 30px to the left and out of the wrapper. Grrr. Strange that when I put the line back in I had to put margin-left: 30px; instead of just the margin-left: 30; (had to add “px”). I wonder why…

    any other suggestions?

    JSDavis82

    (@jsdavis82)

    any other ideas anyone?
    bump.

    Root

    (@root)

    You need to get all the margins, and any padding and borders OUT OF any floated items. That will do it.

    alainS

    (@alains)

    Try conditional tags for IE css

    http://www.quirksmode.org/css/condcom.html

    Nowadays we’re using it a lot. With them I’ve omitted all “nasty” hacks.

    afro

    (@afro)

    Did you end up resolving this? I am having the same issue and am not sure what to do.

    Root

    (@root)

    Well you can go my route. Or conditional CSS. Either way you need to shield IE from the Box Model. Two solutions have been posted.

    this issue, after 8 months, is still not resolved…even after trying all the recommended fixes.

    can anyone else please help? thanks so much!

    bump, issue not resolved. can someone take a look at it and help?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Template Problems in IE’ is closed to new replies.