WordPress.org

Support

Support » Themes and Templates » [Resolved] Syntax error

[Resolved] Syntax error

  • Hi. I need help. I really don’t know what to do. I am new in wordpress. Installed the theme devendo. Background and header was missing. Tried to edit a code. By deleting my try i deleted by mistake a simbol i guess. What can i do? Have no more acess to my admin. Message: syntax error, unexpected ‘}’ in /home/content/p3nexnas03/51/2062751/html/wp-content/themes/Archive1/functions.php on line 810

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello sandramc!

    You can always ‘manually’ deactivate the current theme by FTP. Please go to your /wp-content/themes folder, and rename the Archive1 folder name to something like Archive1-wrong. Actually it doesn’t matter what you are renaming it to, it just matters that you rename it, this way WordPress cannot find the current theme, and fall back to other theme you have in the folder, usually to one of the twenty… themes.

    At this point you should be able to access the admin section. To get rid of the error, you can always deactivate, delete and download again the theme, but this means that you have to start from the beginning also. If you need help finding the error in the code, please upload the functions.php file to Dropbox or Google drive and share the link here, I am happy to take a look for you 🙂

    Cheers,
    Toth Balint BT

    Web Guru
    Member

    @laraib110

    it’ll be more better to just re-install theme , if you don’t know how to solve that change you made … and kindly one thing should always be noted, never make a direct change in your theme …. because any update in future will make your previous change disappear … hope you got point

    I wanna rename the folder in ftp but i do not have access to the hosting manager. Instead of providing me information about hosting managment, the syntax error displays. I asked the provider and i am waiting for an answer. But I am stil waiting for an answer.

    You should be able to log into your hosting provider’s control panel, and use their file manager instead of FTP if that is not accessible. Can I ask you, which hosting company do you use?

    Go daddy

    esmi
    Forum Moderator

    @esmi

    Is this your site?

    Okay, thank you. Please try to follow the steps described here.

    This way you can access GoDaddy’s own File Manager, which is also capable of changing the folder name.

    I have tried it before. The problem is that when i click on webhosting – launch it does not appear other options. It shows just the error message.

    Hi again. Forgot to thank you for ur help. Was really busy. I called the support. This issue is now fixed. Will start again. Now I start with the same problem I had in the beginning, before this whole mess. Header and Background are missing. Can somebody help me?

    esmi
    Forum Moderator

    @esmi

    I suggest you post a new topic about this issue.

    Ok, thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Syntax error’ is closed to new replies.