Support » Installing WordPress » subversion problems

  • Resolved bubazoo


    I upgraded from 2.2.2 to 2.3 using the instructions on the subversion area of the wiki.

    basically, I ran subversion into a directory called “blognew” then copied the plugins and themes I needed into that directory, and the upgrade process was complete.

    however, now its time to upgrade to 2.3.1, so I ran svn update from the command line

    and its saying

    directory “.” is not a valid svn directory

    so…what is the purpose of subversion then? because its not upgrading even when its a subversion copy, this is aggravating, and more difficult then the FTP method in my opinion.

    personally, new version notification does me NO good at all, unless it offers a one-click install for me, otherwise its a pain in the butt to have to

    download the new tar.gz file
    extract it to my HD
    upload all the upgraded files individually using FTP (making sure my FTP program uploads them in the correct format, binary or text, that alone is always a lengthy project, sometimes the FTP transfer fails to upload a file or two, so then you end up having to upload the whole thing again)

    over dialup this takes forever anyway, especially as large as wordpress is getting.

    CPanel’s Fantastico makes all this a breeze normally, but Fantastico has yet to add 2.3.X to its list. Its still using 2.2.X series.

    isn’t there an easier way?

    I mean, I suppose I could run “wget” from a command promot, and untar it using the tar command, but the tar.gz file doesn’t extract to the current directory, so that won’t work. See what i mean? its frustrating.

    and what gets me about it, because I’m not using either of the default themes included with wordpress, thats all I could really do is just “wget” the file, extract it using tar, overwriting existing files. Thats about as easy as it could get besides the Fantastico method, “IF” I could figure out how to extract in the current directory, and not within a subdirectory of the current directory, otherwise you have to copy everything over using

    cp *.* ../blog –reply=yes

    or something to that effect, otherwise it prompts you for every destination file that already exists, and frankly, its a lengthy time consuming process, took me a whole day to do it without errors last time, and it excluded certain files, so that didn’t really work too well either. isn’t there an easier way?

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘subversion problems’ is closed to new replies.