Support » Plugin: Custom Post Type Introductions » Strict Standards warning, but … [RESOLVED]

  • Resolved dirk@d10n

    (@dirkd10n)


    Hi James,

    this is *exactly* what I was looking for the last two days!

    Just a remark:
    I had an annoying “Strict Standards: Redefining already defined constructor for class jck_cpti” error after plugin installation. In my wp_config.php, a line of “error_reporting(E_ALL & ~E_DEPRECATED & ~E_STRICT);” didn’t do the trick. My environment is XAMPP with Apache 2.4.3 and PHP 5.4.7

    Did some googlin’ and found this WP core ticket: http://core.trac.wordpress.org/ticket/20801. So I swapped Yr constructor defs for PHP4 and PHP5 between line 198 and 209 and … bingo! The strict warning is gone.

    Again: a super useful plugin – thanks a bunch!

    Best regards,
    Dirk

    http://wordpress.org/plugins/custom-post-type-introductions/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author jamesckemp

    (@jamesckemp)

    Thanks Dirk,

    I’ll have a look into that one soon! Glad you like, please leave a rating!

    Plugin Author jamesckemp

    (@jamesckemp)

    Should be fixed in 1.0.1. All I had to do was swap the contractors round! Strange.

    Thanks for pointing it out.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Strict Standards warning, but … [RESOLVED]’ is closed to new replies.