WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Strict Mode Error (and fix)

[Resolved] Strict Mode Error (and fix)

  • Hi,
    When using the plugin with WP3.6, I get an error :

    Strict standards: Declaration of Latest_Tweets_Widget::widget() should be compatible with WP_Widget::widget($args, $instance) in /Users/adamr/Documents/Work/Host/HOST-Website/build/content/plugins/latest-tweets-widget/latest-tweets.php on line 240

    Simply removing the ‘array’ keyword in the ‘widget’ function parameters seems to fix this.

    http://wordpress.org/plugins/latest-tweets-widget/

Viewing 1 replies (of 1 total)
  • Plugin Author timwhitlock

    @timwhitlock

    Thanks. I’ve fixed this in the current dev version.

    It’s not an issue with WP3.6, it’s just that you have E_STRICT error reporting enabled. I keep this disabled in WordPress due the amount of legacy code in the ecosystem.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Strict Mode Error (and fix)’ is closed to new replies.