• Resolved giggles420

    (@gigglesslut420)


    After today’s update to 1.6.0 I attempted to update keys. wp_posts and wp_postsmeta failed with this error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near \’key_val_idx/*imfs-query-tag912217792*/\’ at line 1
    Other tables (comments, user, options) appear to have updated OK.

    Uploaded meta id: uqHfV4qJ

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author OllieJones

    (@olliejones)

    Thanks! I’m on it.

    Plugin Author OllieJones

    (@olliejones)

    Your postmeta table has this key, with the name meta key_val_idx in it. Notice that the name of the key has a space in it. Please substitute an actual backtick where I’ve written (backtick). This support forum uses the actual backtick for other purposes.

    CREATE INDEX (backtick)meta key_val_idx(backtick) ON wpg5_postmeta( (meta_key, meta_value(20));

    This plugin doesn’t like that space in your key name. And, the function of the key in question duplicates one of the high-performance keys.

    If you drop the key with the space in its name it works around the problem nicely.

    DROP INDEX (backtick)meta key_val_idx(backtick) ON wpg5_postmeta;

    I’ll fix the bug. https://github.com/OllieJones/index-wp-mysql-for-speed/issues/113

    Thanks for reporting it.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.