Support » Plugin: User Access Manager » SQL Errors

  • Resolved Jason

    (@zushiba)



    I’m getting a lot of errors in my error log regarding UAM.
    [Fri Oct 06 16:21:11.758158 2017] [:error] [pid 6915] [client 35.184.73.193:56824] WordPress database error Unknown column ‘from_date’ in ‘field list’ for query SELECT object_id AS id, object_type AS objectType, from_date AS fromDate, to_date AS toDate\n FROM wp_49_uam_accessgroup_to_object\n WHERE group_id = ‘_none-role_’\n AND group_type = ‘role’\n AND object_id != ”\n AND (general_object_type = ‘_post_’ OR object_type = ‘_post_’) AND (from_date IS NULL OR from_date <= ‘2017-10-06 16:21:11’) AND (to_date IS NULL OR to_date >= ‘2017-10-06 16:21:11’) made by require(‘wp-blog-header.php’), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts, do_action_ref_array, WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, AAM_Frontend_Manager->preparePostQuery, AAM_Core_API::getFilteredPostList, get_posts, WP_Query->query, WP_Query->get_posts, WP_Query->parse_query, do_action_ref_array, WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, UserAccessManager\\Controller\\Frontend\\PostController->parseQuery, UserAccessManager\\Access\\AccessHandler->getExcludedPosts, UserAccessManager\\Access\\AccessHandler->getExcludedObjects, UserAccessManager\\UserGroup\\AbstractUserGroup->getAssignedObjectsByType, UserAccessManager\\ObjectMembership\\PostMembershipHandler->getFullObjects, UserAccessManager\\ObjectMembership\\ObjectMembershipWithMapHandler->getFullObjectsByMap, UserAccessManager\\ObjectMembership\\ObjectMembershipHandler->getSimpleAssignedObjects, UserAccessManager\\UserGroup\\AbstractUserGroup->getAssignedObjects, UserAccessManager\\Database\\Database->getResults

    Any idea what’s causing these?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I also see this issue whilst running latest WordPress (4.8.2) and PHP 5.6.31 on a multisite installation.

    As I have recently upgraded to PHP 5.6, I tried reinstalling the plugin in case DB updates needed to be re-run. I have also tried rolling back the plugin to 1.2.14. Then updating the plugin afresh to no avail.

    NB: There appears to be an if clause when this field is added to the database. Is this a bug in the calling code or a problem with our installations that this field is missing.

    Thanks for your help.

    Plugin Author GM_Alex

    (@gm_alex)

    2.1.4 comes with a database repair option at the backend. Please try this and give feedback if it works.

    @gm_alex Once 2.1.4 is released I will try it out. Is there a particular command I will need to run or will a plugin update call this repair option?

    Thanks again.

    • This reply was modified 10 months, 2 weeks ago by  ta5ae.
    Plugin Author GM_Alex

    (@gm_alex)

    It can be found at the setup section.

    Plugin installed. FYI: Calling just a plugin wp plugin update user-access-manager did not resolve the issue.

    I diffed the code to find the function, I realise that by at the backend you meant through the web and the WordPress admin interface – Dashboard interface.

    After logging into the specific sites with the plugin installed I have seen on the dashboard:

    “Please update the database of the User Access Manager. Click here to proceed”

    After clicking this:

    I have performed the “Repair the database” and “Update User Access Manager database” functions.

    All is well.

    Thanks for the prompt release and fix!

    Jason

    (@zushiba)

    Did this repair database option ever materialize? Because I’m still getting this same error and I still don’t see an option in the latest version to repair the database.

    Plugin Author GM_Alex

    (@gm_alex)

    Yes since 2.1.4 see the comment above from ta5ae…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘SQL Errors’ is closed to new replies.