Support » Fixing WordPress » spam coments

  • ketanco

    (@ketanco)


    although i disabled anyone who is not registered to make a comment, i still found comments from people who are not registered. because i looked at who made those comments and then i compared it with registered users and they were not among registered users. can you tell me what can i do?

Viewing 3 replies - 1 through 3 (of 3 total)
  • ysb8899

    (@ysb8899)

    Try to activate Askimate!

    ketanco

    (@ketanco)

    thats not the problem. the problem is how com users who are not registered can post comment at all? i disabled that. how can they still do it?

    MickeyRoush

    (@mickeyroush)

    thats not the problem. the problem is how com users who are not registered can post comment at all? i disabled that. how can they still do it?

    Possibly through your theme or a poorly coded plugin.

    Try adding this to your .htaccess file:

    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*yourdomain.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule .* - [F]

    From
    http://codex.wordpress.org/Combating_Comment_Spam/Denying_Access

    Don’t forget to change yourdomain.com to your actual TLD.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘spam coments’ is closed to new replies.