Support » Plugin: Content Blocks (Custom Post Widget) » Sometimes the plugin works, sometimes not

  • Resolved 8ung

    (@8ung)



    It is a wunderful plugin. I waited for it a long time. I use it since 1 week for rss-feeds and shopping-tips in every article -> http://www.8ung.info/7124/wetterprognose-september-2016-mittels-der-12-rauhnaechte.

    I hope to explaine my mistakes – in german it would be easier.
    Sometimes the content block button on the post editor works, sometimes not. I don’t know, why. So it would be easier for me, to use a shortcode. I do not see it ([content_block id=7093 slug=tag-wetter-2016]) in the content box or in the editor.

    Is it possibel, to sort the content-blocks by alphabet or category? I only use the plugin since some days, but I have more than 30 blocks up to now.

    Thank you in future – 8ung

    https://wordpress.org/plugins/custom-post-widget/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Johan van der Wijk

    (@vanderwijk)

    The button should appear above the content editor:

    View post on imgur.com

    If it appears intermittently, there might be a network issue or another local problem. Try removing the temporary files of your browser.

    You can sort the content blocks alphabetically on this page by clicking on ‘Title’. It is not possible to do this from the insert content block popup.

    Thank you,
    but I mean other things.

    The german wordpress-support couldn’t help me. So I try it again in english 🙁

    To sort the content blocks alphabetically on this page is easy.
    In the contentbox the titles are sorted by date. I need it sorted by alphabet.
    I cannot find any button for sending a screenshot.

    Thank you in future – 8ung

    Plugin Author Johan van der Wijk

    (@vanderwijk)

    I *think* I now understand what you mean, would like to alphabetically order the custom posts in the select box on the popup:

    View post on imgur.com

    This is not something I am planning to add. If you really need this, you can easily modify line 51 of the plugin file popup.php and replace it with this:

    $args = array( 'post_type' => 'content_block', 'suppress_filters' => 0, 'numberposts' => -1, 'order' => 'ASC', 'orderby' => 'title' );

    Thank you very much, that’s it!

    But there is another mistake too.
    The buttom in the select box sometimes works, sometimes not.
    It doesn’t work by click in the most post of this category
    I don’t know, why.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Sometimes the plugin works, sometimes not’ is closed to new replies.