Support » Plugin: Multipage » Some optical issues

  • Resolved The-Dude

    (@the-dude-1)


    Hi, I love your plugin and have waited eagerly for the update. But when I installed it, I was confronted with some problems.

    1. The table of contents is displayed in a box about half the size of my content column. This causes the content to break unnecessarily. In the previous multipage version, the table of contents ran across the entire width. How do I change the width?

    2. The navigation (Continue or back to intro) is now displayed under the table of contents. Before it was above, what I found much better. Could you please change that or offer an option to display it above or below the table of contents?

    3. The navigation was left-aligned before. Now it is right-aligned. Could you please make it left-aligned again or add an option for left/right-alignment?

    4. If I don’t select any navigation (hidden), the distance to the underlying element is missing. I need the CSS code to increase the distance.

    Thanks for your help! 🙂

    Translated with http://www.DeepL.com/Translator

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author SGr33n

    (@sgr33n)

    Hi, thanks! I appreciate 🙂
    1) You can change it via custom CSS.
    2) I think I can work on this, I just need to do some test.
    3) I don’t remember this, I suppose it’s unchanged, but you can change it via custom CSS.
    4) I will check, thanks for reporting!

    The-Dude

    (@the-dude-1)

    Hi Sergio,

    thank you for you very fast answer! 🙂
    The problem is, i’m not realy good in finding the right selectors and manipulate them. Could your please provide me the code? 🙂

    Cheers! 🙂

    • This reply was modified 7 months ago by  The-Dude.
    • This reply was modified 7 months ago by  The-Dude.
    pgorissen

    (@pgorissen)

    Hi, as a new user I’m having the same issue, the TOC is way too small and therefor inedible.

    I tried to change it using custom CSS (looked them up in the CSS file) but that didn’t work. So any help there would be gratefully appreciated!

    Thanks,
    Patricia

    Plugin Author SGr33n

    (@sgr33n)

    Hi,
    Can I see an example page?

    The-Dude

    (@the-dude-1)

    Can i send you an picture via e-Mail, because i installed the 1.4 Version on my hidden developer site?

    Plugin Author SGr33n

    (@sgr33n)

    Could you use an online service like imgur?

    The-Dude

    (@the-dude-1)

    How it looks with V 1.4: https://imgur.com/yp0O4Oq

    And this is with V 1.3.7: https://imgur.com/4Y6UGPD

    I want that it should like in V 1.3.7 🙂

    Don’t notice the background color (blue) in the first picture.

    • This reply was modified 7 months ago by  The-Dude.
    • This reply was modified 7 months ago by  The-Dude.
    Plugin Author SGr33n

    (@sgr33n)

    Ok, thanks. This can be fixed really easy via CSS, but I cannot provide this kind of support, I’m sorry 🙁 Just make the table 100% instead of 50%.

    The-Dude

    (@the-dude-1)

    Sad to here, that you cannot provide support for your own plugin. ;(
    Ok, i searched for the right CSS-rules. I found this and modified it.

    .mpp-toc-container {
    max-width: 100%; !important;
    }

    .mpp-toc-title h2 {
    text-align: left; !important;
    }

    But it doesn’t work.
    But if i modifie these rules directly in the browser (i.e. Firefox) it works!
    Conclusion: Something overrides my CSS-rules although i explicitly add !important.
    Could you please help me in this point?

    • This reply was modified 7 months ago by  The-Dude.
    Plugin Author SGr33n

    (@sgr33n)

    I cannot support for customizations because this is a free plugin. Anyway remove the ; after 100% and after left and it should work.

    The-Dude

    (@the-dude-1)

    Thx for the hint! The “;” was the troublemaker. Now the TOC looks as it should. 🙂

    But … no offense … you can’t release a very nice piece of code, and let the users alone with them. Even if they only have small requests.
    I think many of them would buy the plugin. So you could earn a little money and the support effort is likely to be limited.

    Please keep up the good work and i hope you continue to develop the plugin. 🙂

    Cheers

    • This reply was modified 7 months ago by  The-Dude.
    The-Dude

    (@the-dude-1)

    Last hint to other users: To make the navigation typ left oder center use this CSS

    /*Multipage Navigation links center*/
    .mpp-page-link {
    text-align: center !important;
    }

    or

    /*Multipage Navigation links left*/
    .mpp-page-link {
    text-align: left !important;
    }

    Plugin Author SGr33n

    (@sgr33n)

    Thanks 😉

    I had the same issue and fortunately the snippet suggested by @the-dude-1 worked just fine (of course after removing the “;”)

    .mpp-toc-container {
    max-width: 100% !important;
    }
    
    .mpp-toc-title h2 {
    text-align: left !important;
    }

    I also agree that even if you’re providing a (great) free plugin you shouldn’t release a new update with a css bug that affects various users, and let them deal alone with them, even if they only have small requests. That’s a bit like providing free inaccurate content to a group of readers, and telling them to search for the right information on their own. It’s easier to correct it for all of them, than asking them to deal with it individually 🙂

    All in all, you have a great plugin, an I don’t rant at all about it. Keep up with the good work and (bug free) updates!

    • This reply was modified 6 months, 2 weeks ago by  nikkoboy.
    Plugin Author SGr33n

    (@sgr33n)

    Thanks, but this is not a bug, it’s wanted 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Some optical issues’ is closed to new replies.