Support » Fixing WordPress » Some database error

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thanks for the support, it solved.

    Can i know when does this happen and how often i have to repair the table ?

    Hi,
    i have been looking through the forum and have tried some of these options but to no success.
    I’ve just upgraded to WP 2.2.1 and have this error:
    —-
    WordPress database error: [Unknown column ‘link_count’ in ‘where clause’]
    SELECT * FROM wp_categories WHERE cat_ID > 0 AND link_count > 0 ORDER BY cat_name ASC
    —-
    I have phpmyadmin and have used the commands to repair the links table to no avial.
    any clues?
    Joe

    further info that may help…
    i only have one link on my blogroll and when i try to delete it i get teh following errro messsage:
    ======

    WordPress database error: [Table ‘joelafferty_wordpad.wp_link2cat’ doesn’t exist]
    SELECT category_id FROM wp_link2cat WHERE link_id = 10 ORDER BY category_id

    WordPress database error: [Table ‘joelafferty_wordpad.wp_link2cat’ doesn’t exist]
    DELETE FROM wp_link2cat WHERE link_id = ’10’

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/vhosts/joelafferty.com/httpdocs/blog/wp-includes/wp-db.php:133) in /var/www/vhosts/joelafferty.com/httpdocs/blog/wp-includes/pluggable.php on line 331
    ——-
    Joe

    oops! i should have put my blog url in so you can see the error on the site:
    =====
    http://www.joelafferty.com/blog/
    —=-

    i also have this error… ><“
    after to 2.2.3….the link will be..(as IMG)
    Error IMG
    How can i fix that ?
    thanks reply… 😉

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Some database error’ is closed to new replies.