WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Sitemaps given a 404 not found error

[Resolved] Sitemaps given a 404 not found error

  • I have several wordpress websites and since updating to WordPress V 3.71 and Yoast SEO V 1.4.19 they all display a 404 not found error for the sitemaps.
    I tried deactivated plugins and changing the theme to the default twentythirteen but the error still existed.
    My sites run various themes including Genesis Child and Twentytwelve.
    When I reverted back to Yoast SEO Plugin V 1.4.18 with WordPress V 3.71 it works.

    http://wordpress.org/plugins/wordpress-seo/

Viewing 8 replies - 1 through 8 (of 8 total)
  • I had the same problem that i’ve just solved, try this:
    http://wordpress.org/support/topic/missing-sitemap-after-upgrade?replies=2

    Thanks, however I did try this when I first had the problem but it didn’t make any difference.

    Today I have install a new wordpress website version 3.71 with Yoast SEO as the only plugin and I still got a 404 error for the sitemap. I put the code below in my Htaccess file before the wordpress rules as recommended by Yoast and now I get a blank white screen. I cannot get this to work on any of my sites since WordPress 3.71 – does anyone know what is causing this issue?

    # WordPress SEO – XML Sitemap Rewrite Fix
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    RewriteRule ^([a-z]+)?-?sitemap.xsl$ /index.php?xsl=$1 [L]
    # END WordPress SEO – XML Sitemap Rewrite Fix

    I have found a series of events which fixes my problem:
    1. Add Sitemap Rewrite Fix rules to very beginning of HTaccess (as above)
    This gives me a blank white sitemap page
    2. Uncheck enable Sitemap functionality on the Yoast SEO Plugin & Save
    3. Check Sitemap functionality & save

    I now have my sitemaps back!
    I hope this helps

    I am having problems as well with my sitemap.

    Same here

    On Webmaster tools,I get :

    Parsing error
    We were unable to read your Sitemap. It may contain an entry we are unable to recognize. Please validate your Sitemap before resubmitting.

    Not working for me 🙁

    I have found a series of events which fixes my problem:
    1. Add Sitemap Rewrite Fix rules to very beginning of HTaccess (as above)
    This gives me a blank white sitemap page
    2. Uncheck enable Sitemap functionality on the Yoast SEO Plugin & Save
    3. Check Sitemap functionality & save

    I now have my sitemaps back!
    I hope this helps

    This does not work for me either

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Sitemaps given a 404 not found error’ is closed to new replies.