• Resolved vesco27

    (@vesco27)


    I got an email from my hosting this morning informing me they took my website offline due to some sitemap issues… see below

    ” This is because the website keeps refreshing itself in the background. I tested this and visiting your website three times generated more than 10,000 hits, the majority of which are in the sitemaps. This causes a lot of requests to your site and also an increase in your data traffic. ”

    Files most frequently repeated are requested by visiting the site:
    10126 “GET /image-sitemap-3.xml
    10143 “GET /image-sitemap-2.xml
    10170 “GET /image-sitemap-1.xml
    10641 “GET /news-sitemap.xml
    10792 “GET /video-sitemap-1.xml
    10847 “GET /image-sitemap-index-1.xml
    10903 “GET /sitemap-1.xml
    11426 “GET /sitemap.xml
    12779 “GET /robots.txt

    I have no idea why this is happening and how I can resolve this…? Yesterday everything was fine and I made no adjustments or changes since then. Can anyone help me out?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • I have deactivated the sitemap temporary and it helps:

    Best regards

    Thread Starter vesco27

    (@vesco27)

    If that triggers my hosting to put me back online, will definitely deactivate! This will work fine as a temporarily solution.

    Hoping for a more permanent one of course!

    Second temporarily solution would be to deactivate YOAST completely.

    @vesco27 this is something I very much like to investigate, unfortunately I can’t reproduce this with a “normal” WordPress installation. Would you mind checking my comment here: https://wordpress.org/support/topic/latest-version-every-single-page-hit-to-request-the-sitemap-overloading-php/#post-12790907 and see if you can provide additional information?

    Thread Starter vesco27

    (@vesco27)

    Will have a look! But the problem is that I don’t see the problems… It’s something they noticed on the server…

    I’m not exactly a pro when it comes to stuff like this. So as willing as I am to provide all kinds of additional information, I just wouldn’t know where to start…

    • This reply was modified 4 years, 1 month ago by vesco27.
    • This reply was modified 4 years, 1 month ago by vesco27.

    @vesco27 ah ok, can you tell me if you use any of the following plugins? Other users with this problem reported these plugins as a common denominator over multiple sites that experienced this issue:

    classic-editor
    wp-rocket
    shortpixel-image-optimiser

    Thread Starter vesco27

    (@vesco27)

    None of the above…

    Thread Starter vesco27

    (@vesco27)

    My hosting put me back online after (me) disabling the xml sitemaps option in your plugin.

    I would love to hear from you when you locate and solve the problem, so I can turn this function back on!

    “A good XML sitemap acts as a roadmap of your website that leads Google to all your important pages.” How does the disabled function affect me at the moment??

    • This reply was modified 4 years, 1 month ago by vesco27.
    • This reply was modified 4 years, 1 month ago by vesco27.
    Thread Starter vesco27

    (@vesco27)

    Okay…

    Yesterday I got a Jetpack error (not connected: 200) when running site diagnoses.

    After disabling the xml sitemaps option in your plugin, that error disappeared on it’s own. Maybe something is conflicting with that plugin??

    Hi @vesco27 thanks for letting us know about Jetpack. It seems your site also has the Jetpack sitemap enabled here. The GET requests from your first post, are requesting the Jetpack sitemap and not Yoast’s sitemap (which is located at sitemap_index.xml when enabled).

    I think there’s definitely some conflict going on here. I’m curious to know what happens if you disabled Jetpack’s sitemap and enabled ours but I’d only recommend that on a staging environment, not your live site. We’ll check into this.

    You only need 1 sitemap, so you should either pick Yoast SEO’s sitemap and disable Jetpack’s or the other way around.

    Thread Starter vesco27

    (@vesco27)

    Okay, didn’t realize I had two active…

    Weird thing though… When I disabled the function in Yoast my hosting let me know the problem was solved. How is that possible if the GET request are Jetpack related? I still had the sitemap function on there (because I didn’t know I had it on twice).

    Also after disabling yours, my search results changed to an older version with previous pictures for this article (for example). Before disabling the xml function in Yoast the picture was up to date in Google, now it’s using the previous version from a while back…

    @vesco27
    We can see you have enabled JetPack’s sitemap here https://saudadesdeportugal.nl/sitemap.xml. Google is likely using this sitemap to output data into the SERPs.

    We are not sure why disabling Yoast resolved the issue with JetPack’s sitemaps GET requests.

    This all sounds like a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:

    1. Are all your non-Yoast plugins and themes also updated?

    2. Can you confirm your server has all the right requirements?  If you are not sure, speak to your host provider. This guide explains more: https://kb.yoast.com/kb/plugin-requirements/.

    3. Please perform a conflict check by enabling Yoast and then disabling all the non-Yoast plugins and switching over to a basic theme like 2016. This guide explains more: https://kb.yoast.com/kb/how-to-check-for-plugin-conflicts

    When Yoast is the only plugin active and you are on a basic theme are you still getting those sitemap issues?

    If not, please re-enable each plugin one at a time until you locate the offending plugin. Let us know which one it is.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Thread Starter vesco27

    (@vesco27)

    I was taken offline by my hosting again… The same problem occurred. I now disabled the Jetpack xml and turned the function back on in Yoast. Problem is, I now have to hear back from my hosting if this solves the problem or not…

    Thread Starter vesco27

    (@vesco27)

    For now I am back online. But the same thing happened last week. It seems like the problem is solved (for now), but I have no idea how it will react in the near future. The Jetpack xml is switched off now, Yoast xml is turned on. Fingers crossed…

    I am using a customized theme (SKT Girlie Pro Child) and don’t feel comfortable switching to a basic theme to investigate further. Too afraid all my settings/adjustments will get lost… That happened before, the horror!

    All is up to date!

    Plugin Support devnihil

    (@devnihil)

    @vesco27 Please let us know whether disabling the Jetpack sitemap resolves the issue.

    As for checking for conflicts and testing with a default theme, we can imagine that deactivating your plugins or switching themes on a production site isn’t the best way to go. Have you ever considered setting up a staging environment for your tests? This means that you can do all the testing and only change the live site when all works like intended.Your host might be able to helpSome popular web hosts offer quick setups for a staging site so please contact your web host for assistance. They will probably be able to help you out.Alternative options to set up a staging environmentIf your web host does not offer staging sites, the WordPress plugin repository offers staging plugins or you can create your own staging site.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Sitemap xml issues’ is closed to new replies.