Support » Plugin: Ajaxify WordPress Site(AWS) » Site Navigation not working

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Manish Kumar Agarwal

    (@manishkrag)

    I need credentials to check. My details shared in aws php file.

    Hi,

    I’m also having the same problem – the plugin was working fine until I updated it today. Now site links will only ajax load the first page.

    I can get the links to load properly by changing the ‘menu container class’ in the options panel to a class that does not exist on my pages. Of course, then my menu doesn’t update itself properly, but at least all the links are ajax loading.

    Again, I haven’t changed anything else on the site, except update this plugin – so I think this update may have introduced a bug. Of course it could just be an issue with my site, too.

    yeah.. same thing here.. if i change the navigation class name in the options panel it works..

    it seems that rolling back ajaxify.js to version 1.5.1 fixes my problem. Unless I’m mistaken, the only changes are that the .live() function was replaced with .go()

    Plugin Author Manish Kumar Agarwal

    (@manishkrag)

    Whoever having this problem please check your jquery.js file version. AWS js codes are written as per the latest version as few functions like .live no more in jquery latest version.

    Solution: Either one
    #1: Upgrade your jquery core file.
    or
    #2: Open ajaxify.js file replace .on by .live

    That’s your problem solved. Hope this will helpful for all of you.

    Anyways I had fixed the same problem personally on ‘marc-andrew‘ and few others.

    I had this same issue. I first tried changing .on to .live, which worked nicely.
    I then tried switching back to .on and enqueuing jquery 2.1.0 but experience the same problem again.
    I’m doing this testing on a fresh WP install with twentythirteen and no other plugins.

    Good work so far, thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Site Navigation not working’ is closed to new replies.