Support » Plugin: WooCommerce » Shipping Details Missing from Checkout

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    How can I enable the same fields for shipping as billing with a check box to copy billing details if they are the same?

    Do you have shipping enabled? Check at WooCommerce > General to ensure. Then go to WooCommerce > Shipping > Shipping options and make sure you don’t have “Force shipping to the customer billing address” checked.

    Once you do that, there should be a new checkbox that will let users enter different shipping credentials: http://cld.wthms.co/RE0C/3VL2EuFE. You won’t need a “copy” button, as they can just uncheck the “Ship to a different address?” option.

    I think all my settings are correct, but I took some screenshots.

    Could it be that I only have Paypal enabled at the moment, and not PayPal Powered by Braintree or Stripe?

    Plugin Contributor Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    Could it be that I only have Paypal enabled at the moment, and not PayPal Powered by Braintree or Stripe?

    No, that should not affect your shipping.

    You still don’t have the option to select a different shipping address at checkout? Something on your site must be causing a conflict. Try temporarily switching back to the WordPress Twenty Sixteen Theme, or Storefront, and disable all plugins except for WooCommerce. If that resolves the issue, then slowly re-enable features until you find the one that’s causing the conflict.

    I’m having exactly the same problem. Everything seems to be ok. But the Shipping Address doesn’t appear on the checkout page, only in the My Account page.
    I wanted a tab or something asking if the shipping address is the same as the billing address and if not I wanted it to be redirected to a page where they would define the shipping details.

    Plugin Contributor Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    Hi hmarques,

    Please open up your own support thread per the forums rules. Be sure to try the steps listed above for debugging first though.

    same problem here. Is there a solution yet?

    Same issue, solution yet?

    I figured it out: you have to created shipping zones in WooCommerce>Settings>Shipping.

    Great, @ballmouse. I had “rest of the world” zone created, but to get it working I had to create a shipping method within this zone.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.