Support » Plugin: WooCommerce » Settings>Display>Shop page

  • Resolved BowlOfCherries

    (@bowlofcherries)



    My WooCommerce setting for “Shop page” is simply “shop.” Why does the URL display as “shop-2”?

    The product permalink is set for “custom base,” “/shop/”

    I want the URL to be “http://www.smallbones.ca/shop.” How do I do that?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi , I think the might simple way to do that is redirect – 301 your url to shop , but take care about this. If you need some help about the problems of redirection 301 ask =D.

    Go to the list of pages and make sure you don’t have a shop page in the bin. If so, delete it permanently. Then find the shop page in the list of pages, edit, then edit the permalink (just under the page title).

    Lorro, thank-you, but I don’t understand. You said to delete the shop page in the list of pages (yes, it is there, along with the cart, checkout, policies, etc), then find it and edit. If I delete it, it won’t be there!

    Thanks to you, too, daieledti. I know how to redirects, but when you visit my shop page, it’s the url I posted above. If I redirect that to what I want, I imagine it would lead to a 404.

    Maybe I just found my own answer. The slug for the page had the -2 in it. I deleted that & I’ll do a redirect to see if that works.

    Noooooo, don’t delete the current shop page – look for an old shop page in the bin / trash, and if found, delete that one permanently. Then you can edit the permalink for the current shop page.

    This is because you can’t have two pages with the same permalink, even if one is in the bin.

    No need for a redirect.

    There wasn’t a ‘shop’ in the bin. It’s okay now, as what I did has worked.

    Thank-you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Settings>Display>Shop page’ is closed to new replies.