Support » Plugin: WP-Members Membership Plugin » Select2 conflict with ACF Pro

  • Resolved kenjigarland

    (@kenjigarland)


    Hi there! Thanks for this super useful plugin.

    I’m working on a site that uses both WP-Members and [Advanced Custom Fields Pro](https://www.advancedcustomfields.com), and unfortunately it looks like as of WP-Members version 3.2.2, they’re loading two different versions of the Select2 JS library that are conflicting with one another. This makes ACF-generated dropdown fields unusable in the WP admin interface.

    It looks like the simplest way to resolve this conflict on the WP-Members side would be to:
    * Change the version of Select2 that WP-Members relies on from 3.4.8 to the latest (currently 4.0.5)
    * Make sure that the fourth argument to both wp_register_style() and wp_register_script() is the correct version number (instead of '1.0'), so that other plugins that also rely on select2 can tell which version WP-Members is using

    Please let me know if I can provide any other info.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Chad Butler

    (@cbutlerjr)

    Thanks – yes, this is an issue I am aware of and am preparing an update to resolve it (and a couple of other smaller issues). There is an update pending that will address it. It will release as 3.2.3, and will ship as soon as I’ve confirmed that all known issues are resolved.

    Oh, great – thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Select2 conflict with ACF Pro’ is closed to new replies.