• Resolved Indent

    (@indent)


    I’ve been using Wordfence (free version) couple of months with no problems. I don’t understand why it suddenly says “The current scan looks like it has failed.” I’ve added define('WORDFENCE_SCAN_FAILURE_THRESHOLD', 600); in wp-config.php, also edited the Scan Options & Scheduling > Performance Options > Maximum execution time for each scan stage to 20. The scan always stops at 5554 analyzed files with notification of “Scan Failed”. Any suggestions?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author WFSupport

    (@wfsupport)

    Can you do the following so I can get the information I need to help you?

    * Kill the existing scan if it is still running (The “Start New Scan” button turns in to a “Stop” button while the scan is running)
    * Go to your Scan > Scan Options and Scheduling page and locate the “Performance Options”
    * Set “Maximum execution time for each scan stage” to 20 on the options page
    * Click to “Save Changes”
    * Go to the Tools > Diagnostics page
    * In the “Debugging Options” section check the circle “Enable debugging mode”
    * Click to “Save Changes”.
    * Start a new scan
    * Copy the last 20 lines from the Log (click the “Show Log” link) or so of the activity log and paste them here

    Tim

    Thanks for your response. The diagnostic page is blank. If I drop a phpinfo() file on the server I get all the PHP info, so I guess that’s not disabled.

    Plugin Author WFSupport

    (@wfsupport)

    Can you try a complete reinstall? Make sure and select the option (Global Options page) to Delete all wordfence tables and data and save the changes first.

    This will remove all your settings so you may want to export the settings on the Wordfence Tools > Import/Export page first. Also remove extended protection on the firewall.

    Let me know how it goes.

    Tim

    Indent

    (@indent)

    Hi, sorry I took so long to get back to you.

    I followed your instructions, but when I try to activate a fresh install of the plugin I get an internal server error 500 (?).

    Don’t know if this is relevant, but I’m using SSL.

    Jan

    Plugin Author WFSupport

    (@wfsupport)

    Did you completely delete the wordfence plugin folder in wp-content/plugins? If not can you try that using FTP and then reinstall Wordfence from the plugins > add new page on your site?

    Tim

    Indent

    (@indent)

    Yes, I deleted Wordfence plugin folder, wflogs folder, wordfence-waf.php, user.ini, Wordfence WAF in .htaccess and all wp_wf-tables.

    Indent

    (@indent)

    Installed Wordfence via “plugins > add new”, same error.

    Plugin Author WFSupport

    (@wfsupport)

    Can you check the server error logs for any messages around the time this happens?

    Tim

    Indent

    (@indent)

    From the server error log:

    /wp-admin/plugins.php?plugin_status=all&paged=1&s” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36″ WordPress database error Table ‘d27462.wp_wfConfig’ doesn’t exist for query SELECT name, val, autoload FROM wp_wfConfig WHERE name = ‘allowLegacy2FA’ made by activate_plugin, include_once(‘/plugins/wordfence/wordfence.php’), require_once(‘/plugins/wordfence/lib/wordfenceClass.php’), wfCredentialsController::useLegacy2FA, wfCredentialsController::allowLegacy2FA, wfConfig::get

    /wp-admin/plugins.php?plugin_status=all&paged=1&s” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36″ WordPress database error Table ‘d27462.wp_wfConfig’ doesn’t exist for query SELECT name, val, autoload FROM wp_wfConfig WHERE name = ‘debugOn’ made by activate_plugin, include_once(‘/plugins/wordfence/wordfence.php’), wordfence::install_actions, wordfence::runInstall, wordfence::status, wordfence::isDebugOn, wfConfig::get

    /wp-admin/plugins.php?plugin_status=all&paged=1&s” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36″ /opt/php/bin/default: symbol lookup error: /opt/php/bin/default: undefined symbol: curl_mime_free

    /wp-admin/plugins.php?plugin_status=all&paged=1&s” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36″ End of script output before headers: plugins.php

    /wp-admin/plugins.php?plugin_status=all&paged=1&s” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36” /opt/php/bin/default: symbol lookup error: /opt/php/bin/default: undefined symbol: curl_mime_free

    Plugin Author WFSupport

    (@wfsupport)

    It looks like all the tables aren’t being created. wfconfig is very important. Check your database permissions because “CREATE” may be missing.

    Tim

    Indent

    (@indent)

    I have to check with the web host about user privileges because that option is disabled in phpMyAdmin, but I see that when I try to activate the plugin all WF tables are created, wp_wfconfig table is also created and has 186 rows. Content > wflogs folder is also created, no changes in .htaccess though.

    • This reply was modified 2 months ago by Indent.
    • This reply was modified 2 months ago by Indent.
    • This reply was modified 2 months ago by Indent.
    Plugin Author WFSupport

    (@wfsupport)

    Thanks for letting us know.

    Can you try these steps again so we can see the scan log entries?

    * Kill the existing scan if it is still running (The “Start New Scan” button turns in to a “Stop” button while the scan is running)
    * Go to your Scan > Scan Options and Scheduling page and locate the “Performance Options”
    * Set “Maximum execution time for each scan stage” to 20 on the options page
    * Click to “Save Changes”
    * Go to the Tools > Diagnostics page
    * In the “Debugging Options” section check the circle “Enable debugging mode”
    * Click to “Save Changes”.
    * Start a new scan
    * Copy the last 20 lines from the Log (click the “Show Log” link) or so of the activity log and paste them here

    Tim

    I’m not sure how that’s possible.

    Can you try a complete reinstall? Make sure and select the option (Global Options page) to Delete all wordfence tables and data and save the changes first.

    This will remove all your settings so you may want to export the settings on the Wordfence Tools > Import/Export page first. Also remove extended protection on the firewall.

    Let me know how it goes.

    Tim

    Hi, sorry I took so long to get back to you.

    I followed your instructions, but when I try to activate a fresh install of the plugin I get an internal server error 500 (?).

    Don’t know if this is relevant, but I’m using SSL.

    Jan

    Did you completely delete the wordfence plugin folder in wp-content/plugins? If not can you try that using FTP and then reinstall Wordfence from the plugins > add new page on your site?

    Tim

    Yes, I deleted Wordfence plugin folder, wflogs folder, wordfence-waf.php, user.ini, Wordfence WAF in .htaccess and all wp_wf-tables.

    Plugin Author WFSupport

    (@wfsupport)

    Until we hear back from the hosting provider about the database permissions I don’t think there is anything further we can do. The last errors you sent showed the tables weren’t created.

    Tim

    I finally got word from my hosting provider, the problem was with the compiling in their version of PHP 7.3. With PHP 7.2 everything worked just fine. I’m a little frustrated, to say the least, as are you I imagine. What a waist of time.

    Thanks for not giving up on this.

    J

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.